Bug 133470 - Backspace key does not delete umlauted-character
Summary: Backspace key does not delete umlauted-character
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-24 09:01 UTC by Need Real Name
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-10 15:18:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2004-09-24 09:01:05 UTC
I'm not sure if this is an ssh bug, a pango bug, or a gnome-terminal
bug. Sorry about that.

I am using a German keyboard.
When deleting an umlaut-character, the backspace key appears to work
but a space is actually substituted.

1. ssh to Suse 9 box/debian 3 box
2. enter the characters "aaaöbbb" (umlaut o between aaa and bbb)
3. Press backspace until just "aaa" is visible. Type "bbb"
4. You now have "aaabbb", press enter
5. The error message I get is:
 -bash: aaa bbb: command not found
i.e. what looks like a space appears between "aaa" and "bbb".

Doesn't happen when I ssh to localhost. UFT8 handling bug?

Comment 1 Ray Strode [halfline] 2004-11-10 15:18:54 UTC
Hi,

The problem is that gnome-terminal is running under UTF-8 and your
remote machines are running in non-UTF8 locales.  In order for things
to work well, you need to inform gnome-terminal what encoding the
remote machine works on.  You can do that from the "Set Character
Encoding" submenu of the "Terminal" menu.  You may find more
information about this problem by visiting bug 75805 which is related.

Thanks.





Note You need to log in before you can comment on or make changes to this bug.