Bug 1334736 - On the LAN network, as long as the VMs receive the Network message, and will always blue screen.
Summary: On the LAN network, as long as the VMs receive the Network message, and will ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.3
Hardware: Unspecified
OS: Windows
high
high
Target Milestone: rc
: 7.3
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1334963 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-10 12:28 UTC by Qingzheng zhang
Modified: 2016-11-04 08:54 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:54:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
the message on my LAN network (466 bytes, application/octet-stream)
2016-05-10 12:28 UTC, Qingzheng zhang
no flags Details
the dump file in the VMs (262.88 KB, application/octet-stream)
2016-05-11 00:59 UTC, Qingzheng zhang
no flags Details
the special network massage (466 bytes, application/octet-stream)
2016-05-23 00:52 UTC, Qingzheng zhang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Qingzheng zhang 2016-05-10 12:28:07 UTC
Created attachment 1155730 [details]
the message on my LAN network

Description of problem:
On the LAN network, as long as the VMs receive the Network message, and will always blue screen.

Version-Release number of selected component (if applicable):
My VMs are windows 7 or windows 2008r2.
The NIC must be virtio Card.
Drive version:
virtio-win-0.1.102 and virtio-win-0.1.117


How reproducible:


Steps to Reproduce:
1.root@cvknode5:~# virsh    domiflist    win7_vs 
Interface  Type       Source     Model       MAC
-------------------------------------------------------
vnet4          bridge     vswitch0   virtio      0c:da:41:1d:80:b5
vnet5          bridge     vswitch0   rtl8139     0c:da:41:1d:5d:c2

2.root@cvknode5:~# tcpreplay -i vnet4 2603.pcap


Actual results:
then, the VM goes to blue screen.

Expected results:


Additional info:
And WinDbg gives the fault:
FOLLOWUP_IP: 
netkvm!CNdisList<CNB,CLockedAccess,CCountingObject>::ForEachDetached<<lambda_6b961a6dc38b31cdd9784b2bad94bb76> >+2a [c:\cygwin64\tmp\build\source\internal-kvm-guest-drivers-windows\netkvm\common\parandis-util.h @ 232]
fffff880`0315a8d6 0fb702          movzx   eax,word ptr [rdx]
FAULTING_SOURCE_CODE:  
   228:     template <typename TFunctor>
   229:     void ForEachDetached(TFunctor Functor)
   230:     {
   231:         CLockedContext<TAccessStrategy> LockedContext(*this);
>  232:         while (!IsListEmpty(&m_List))    
   233:         {
   234:             Functor(Pop_LockLess());
   235:         }
   236:     }
   237:

Drive version:
virtio-win-0.1.102 and virtio-win-0.1.117
Download from
 https://fedorapeople.org/groups/virt/virtio-win/direct-downloads/stable-virtio/virtio-win.iso
and https://fedorapeople.org/groups/virt/virtio-win/direct-downloads/latest-virtio/virtio-win.iso

Comment 1 Qingzheng zhang 2016-05-11 00:59:44 UTC
Created attachment 1155943 [details]
the dump file in the VMs

Comment 2 Qingzheng zhang 2016-05-11 01:03:15 UTC
/var/log/libvirt/qemu/win7_vs.log:

2016-05-10 18:35:01.554+0000: starting up libvirt version: 1.3.0, qemu version: 2.1.2, hostname: cvknode5
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin QEMU_AUDIO_DRV=none /usr/bin/kvm -name win7_vs -S -machine pc-i440fx-2.1,accel=kvm,usb=off,system=windows -cpu qemu64,hv_time,hv_relaxed,hv_spinlocks=0x2000 -m size=4194304k,slots=10,maxmem=1073741824k -smp 1,maxcpus=8,sockets=8,cores=1,threads=1 -numa node,nodeid=0,cpus=0,mem=4096 -uuid 3799b110-5bfb-4004-bc76-c0ce267c19b2 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-win7_vs/monitor.sock,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,clock=vm,driftfix=slew -no-hpet -no-shutdown -boot strict=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device usb-ehci,id=usb1,bus=pci.0,addr=0x4 -device nec-usb-xhci,id=usb2,bus=pci.0,addr=0x5 -device virtio-scsi-pci,id=scsi1,bus=pci.0,addr=0x6 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -drive if=none,id=drive-ide0-0-0,readonly=on,format=raw -device ide-cd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=2 -drive file=/vms/images/win7_sp1_x86_base.img,if=none,id=drive-ide0-0-1,format=qcow2,cache=directsync -device ide-hd,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1,bootindex=1 -drive file=/vms/isos/virtio-win7.vfd,if=none,id=drive-fdc0-0-0,readonly=on,format=raw,cache=directsync -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,fd=30,id=hostnet0,vhost=on,vhostfd=32 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=0c:da:41:1d:80:b5,bus=pci.0,addr=0x3 -netdev tap,fd=33,id=hostnet1 -device rtl8139,netdev=hostnet1,id=net1,mac=0c:da:41:1d:5d:c2,bus=pci.0,addr=0x8 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/win7_vs.agent,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=org.qemu.guest_agent.0 -device usb-tablet,id=input0,bus=usb.0 -vnc 0.0.0.0:1 -device VGA,id=video0,vgamem_mb=16,bus=pci.0,addr=0x2 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x9 -msg timestamp=on

Comment 3 Yan Vugenfirer 2016-05-22 09:00:19 UTC
Hi,

Can you please attach the replayed file as well? What was special about it?

Best regards,
Yan.

Comment 4 Qingzheng zhang 2016-05-23 00:52:02 UTC
Created attachment 1160431 [details]
the special network massage

Comment 5 Qingzheng zhang 2016-05-23 01:05:56 UTC
(In reply to Yan Vugenfirer from comment #3)
> Hi,
> 
> Can you please attach the replayed file as well? What was special about it?
> 
> Best regards,
> Yan.

Thank you for taking time to solve my unbearable problem!

I have attach the network message caused the bug.
I captured the packets on my LAN network by tcpdump command. And I have found the network message caused the bug.
But,I don't know what special about it.

Comment 6 Qingzheng zhang 2016-07-12 08:35:47 UTC
(In reply to Yan Vugenfirer from comment #3)
> Hi,
> 
> Can you please attach the replayed file as well? What was special about it?
> 
> Best regards,
> Yan.

Hi,

Is this problem solved?
Thank you very much.

Best regards.

Comment 7 Yan Vugenfirer 2016-07-12 09:15:07 UTC
(In reply to Qingzheng zhang from comment #6)
> (In reply to Yan Vugenfirer from comment #3)
> > Hi,
> > 
> > Can you please attach the replayed file as well? What was special about it?
> > 
> > Best regards,
> > Yan.
> 
> Hi,
> 
> Is this problem solved?
> Thank you very much.
> 
> Best regards.

Yes. The commit is in upstream code commits https://github.com/YanVugenfirer/kvm-guest-drivers-windows/commit/754481432c7374b6d404fcd133006b53695dab44 to https://github.com/YanVugenfirer/kvm-guest-drivers-windows/commit/976828bd46efde5d57a54d7a825ef3ad443e0870

We are working to release the binaries with the fix.

Comment 8 Qingzheng zhang 2016-07-12 09:23:49 UTC
(In reply to Yan Vugenfirer from comment #7)
> (In reply to Qingzheng zhang from comment #6)
> > (In reply to Yan Vugenfirer from comment #3)
> > > Hi,
> > > 
> > > Can you please attach the replayed file as well? What was special about it?
> > > 
> > > Best regards,
> > > Yan.
> > 
> > Hi,
> > 
> > Is this problem solved?
> > Thank you very much.
> > 
> > Best regards.
> 
> Yes. The commit is in upstream code commits
> https://github.com/YanVugenfirer/kvm-guest-drivers-windows/commit/
> 754481432c7374b6d404fcd133006b53695dab44 to
> https://github.com/YanVugenfirer/kvm-guest-drivers-windows/commit/
> 976828bd46efde5d57a54d7a825ef3ad443e0870
> 
> We are working to release the binaries with the fix.

ok,I've seen the commits.
Thank you!

Comment 9 Yan Vugenfirer 2016-08-01 15:09:49 UTC
*** Bug 1334963 has been marked as a duplicate of this bug. ***

Comment 10 lijin 2016-08-02 05:46:48 UTC
Reproduced this issue on virtio-win-prewhql-117
Verified this issue on virtio-win-prewhql-124

steps same as comment #0

Actual Results:
on virtio-win-prewhql-117,guest bsod immediately after receive the network message.
on virtio-win-prewhql-124,guest works well,no bsod

Based on above ,this issue has been fixed already.




package info:
    virtio-win-prewhql-0.1-124
    kernel-3.10.0-481.el7.x86_64
    qemu-kvm-rhev-2.6.0-16.el7.x86_64
    seabios-bin-1.9.1-4.el7.noarch

qemu cli:
/usr/libexec/qemu-kvm -name virt-tests-vm1 -M pc -nodefaults -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=04 -drive id=drive_image1,if=none,aio=native,cache=none,file=win7-64-sp1-virtio.qcow2 -device scsi-hd,id=image1,drive=drive_image1,bootindex=1 -m 4096 -smp 4 -drive id=drive_cd1,if=none,aio=native,cache=none,media=cdrom,file=en_windows_7_ultimate_with_sp1_x64_dvd_u_677332.iso -device ide-drive,id=cd1,drive=drive_cd1,bus=ide.0,unit=0 -drive id=drive_winutils,if=none,cache=none,aio=native,media=cdrom,file=/usr/share/virtio-win/virtio-win.iso -device ide-drive,id=winutils,drive=drive_winutils,bus=ide.0,unit=1 -drive id=drive_unattended,if=none,aio=native,cache=none,media=cdrom,file=virtio-win-prewhql-124.iso -device ide-drive,id=unattended,drive=drive_unattended,bus=ide.1,unit=0 -rtc base=localtime,clock=host,driftfix=none -boot menu=on -usb -device usb-tablet -vga cirrus -vnc :2 -device pvpanic,id=pvpanic0,ioport=0x050 -monitor stdio -netdev tap,script=/etc/qemu-ifup,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=0c:da:41:1d:80:b5 -enable-kvm

Comment 12 errata-xmlrpc 2016-11-04 08:54:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.