Bug 133477 - xinitrc still refers to /etc/X11/XF86Config instead of /etc/X11/xorg.conf
Summary: xinitrc still refers to /etc/X11/XF86Config instead of /etc/X11/xorg.conf
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xinitrc   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-24 10:56 UTC by Stefan Hoelldampf
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 12:25:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stefan Hoelldampf 2004-09-24 10:56:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10

Description of problem:
In xinitrc-4.0.4-1 are references to the file /etc/X11/XF86Config
which should be /etc/X11/xorg.conf.

Especially the files Xsession and xinitrc are affected.

Version-Release number of selected component (if applicable):
xinitrc-4.0.4-1

How reproducible:
Always

Steps to Reproduce:
1. search for "/etc/X11/XF86Config" in the sources of xinitrc

Comment 1 Mike A. Harris 2004-09-24 11:55:26 UTC
Thanks for the report.

Hmm, indeed that is some ugly code in there.  It should never
be parsing config files directly, as there is no way to know
exactly which config file is used.  The X server can use
config files from other locations, etc.

I think the existing code in Xsession et al. is very very ancient
and stale, probably from the Red Hat Linux 4.x or 5.x days, and
we can probably just remove that code block entirely.

Need to investigate it a bit more first.

Comment 2 Mike A. Harris 2004-09-24 12:25:47 UTC
Ok, the code that parsed the config files indeed was for Xsun
X servers in XFree86 3.3.6 for sparc platform back in the
RHL 5.x or 6.x days.  I found some ancient bug reports to
that effect.  I've removed all of the hacks, as it is not
necessary nowadays since we don't support sparc nor 3.3.6
X servers any longer.

There's sure a lot of code duplication between the Xsession and
xinitrc files I notice.  I think I'll try to remove code
duplication into a 'common' script.

Thanks again for reporting.

Updated xinitrc will be in rawhide soon.

Setting status to "RAWHIDE" xinitrc 4.0.5-1


Note You need to log in before you can comment on or make changes to this bug.