Bug 1334777 - Missing documentation in self-hosted engine guide 3.6 about storage
Summary: Missing documentation in self-hosted engine guide 3.6 about storage
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation   
(Show other bugs)
Version: 3.6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.7
: ---
Assignee: Julie
QA Contact: Byron Gravenorst
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-10 14:01 UTC by ahauser
Modified: 2016-06-06 09:54 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-06 04:36:46 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Docs
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ahauser 2016-05-10 14:01:40 UTC
Description of problem:

When following the self-hosted engine installation guide 3.6, when the engine is deployed, when accessing the web interface, the default datacenter isn't initialized, no storage and VM are detected.
Nothing in the documentation explains it is a normal behavior and nothing explains a default datastore must be added to get started.
There should be at least a mention of it and a link to this page from another guide to configure storage and get started with the manager:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Installation_Guide/chap-Configuring_Storage.html



Version-Release number of selected component (if applicable):

Self-hosted engine guide 3.6


How reproducible:


Steps to Reproduce:
1. Follow the self-hosted documentation
2. Deploy the Self-hosted engine
3. Connect to the Manager web interface

Actual results:

The default datastore is unitialized, with no information, which looks like an error.

Expected results:

The documentation should explain it is the normal behavior, not an error, and should explain a default datastore domain should be added to get started.


Additional info:
I had to open a bug to have explanations about it and to understand it was a problem of documentation.
Please check : https://bugzilla.redhat.com/show_bug.cgi?id=1332642

Comment 1 Julie 2016-05-23 23:04:16 UTC
Hi ahauser,
   Thanks for filing this bug. In the current documentation[1][2], we have a paragraph saying:
-----
You can log in as the admin@internal user to continue configuring the Manager and add further resources. You need to create another data domain to host regular virtual machine data and for the Manager virtual machine to be visible in the Administration Portal. 
----- 

However, I also agree this may not be clear enough. I'd suggest linking to the Admin Guide[3] instead of the Installation Guide as it contains more storage options. Please feel free to note down any other feedback you have.  

[1] https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html-single/Self-Hosted_Engine_Guide/index.html#Configuring_Self-Hosted_Engine_on_Red_Hat_Enterprise_Virtualization_Hypervisor
[2] https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html-single/Self-Hosted_Engine_Guide/index.html#Configuring_the_Self-Hosted_Engine
[3] https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Administration_Guide/chap-Storage.html

Many thanks,
Julie

Comment 2 Julie 2016-05-24 01:05:37 UTC
Hi ahauser,
   I have added the following important box to the end of the procedure:
-----------
Important
Log in as the admin@internal user to continue configuring the Manager and add further resources. You must create another data domain for that data center to be initialized to host regular virtual machine data. See Storage (https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Administration_Guide/chap-Storage.html) in the Administration Guide for different storage options and on how to add a data storage domain. 
-----------

Would this meet your requirements?

Kind regards,
Julie

Comment 3 ahauser 2016-05-24 07:58:19 UTC
Hi,


Thank you for answering my request. 
Yes, I think it's a really good idea. 
Maybe this box should be added to the 2 links we talked about.

Comment 7 ahauser 2016-06-06 09:09:58 UTC
thank you

Comment 8 Julie 2016-06-06 09:54:04 UTC
(In reply to ahauser from comment #7)
> thank you

Many thanks again for your help in improving the documentation! :)

Kind regards,
Julie


Note You need to log in before you can comment on or make changes to this bug.