Bug 1334801 - python-oslo-service: Provide a Python 3 subpackage
Summary: python-oslo-service: Provide a Python 3 subpackage
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-oslo-service   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Haïkel Guémar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PYTHON3
TreeView+ depends on / blocked
 
Reported: 2016-05-10 14:40 UTC by Tomas Orsava
Modified: 2016-05-17 15:12 UTC (History)
5 users (show)

Fixed In Version: python-oslo-service-1.7.0-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-17 15:12:52 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tomas Orsava 2016-05-10 14:40:59 UTC
Upstream, this software supports Python 3. Please provide a Python 3
package for Fedora.


According to the Python packaging guidelines [0], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [1].

The current best practice is to provide subpackages for the two Python
versions (called "Common SRPM" in the guidelines). Alternatively, if
nothing depends on your Python2 package, you can just switch to Python 3
entirely.

It's OK to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 24 as well.


If you need more instructions, a guide for porting Python-based RPMs is
available at [2].
If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] https://fedoraproject.org/wiki/Packaging:Python
[1] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
[2] http://python-rpm-porting.readthedocs.io/

Comment 1 Javier Peña 2016-05-10 14:51:27 UTC
python-oslo-service already has a Python3 subpackage:

- Rawhide: http://koji.fedoraproject.org/koji/buildinfo?buildID=754713
- F24: http://koji.fedoraproject.org/koji/buildinfo?buildID=754742, pushed to stable 3 days ago via https://bodhi.fedoraproject.org/updates/FEDORA-2016-af98a85b1f

Has this bug been opened automatically by mistake?

Comment 2 Tomas Orsava 2016-05-11 08:19:51 UTC
Hi Javier!

I apologize, this preprepared message is usually enough but doesn't mention all corner cases.
In the case of python-oslo-service the issue is that there is a Python 2 subpackage (python-oslo-service-tests) without an equivalent Python 3 subpackage. So while the dependency on Python 2 was lowered, it was not eliminated completely.

Comment 3 Fedora Update System 2016-05-11 16:42:03 UTC
python-oslo-service-1.7.0-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-53210b2fa0

Comment 4 Javier Peña 2016-05-11 16:42:24 UTC
(In reply to Tomas Orsava from comment #2)
> Hi Javier!
> 
> I apologize, this preprepared message is usually enough but doesn't mention
> all corner cases.
> In the case of python-oslo-service the issue is that there is a Python 2
> subpackage (python-oslo-service-tests) without an equivalent Python 3
> subpackage. So while the dependency on Python 2 was lowered, it was not
> eliminated completely.

Thanks Tomas, now I understand the issue :). New builds are on the way.

Comment 5 Fedora Update System 2016-05-12 09:40:56 UTC
python-oslo-service-1.7.0-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-53210b2fa0

Comment 6 Fedora Update System 2016-05-17 15:12:49 UTC
python-oslo-service-1.7.0-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.