Bug 133481 - Updates to the time aren't reflected in clock display
Updates to the time aren't reflected in clock display
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-24 07:49 EDT by Jay Turner
Modified: 2015-01-07 19:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 05:03:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2004-09-24 07:49:52 EDT
Description of problem:
With gnome-panel-2.7.92.1-1, I set the time to EDT when I initially
setup the system, then after relocating to Europe, ran
"system-config-date" to modify the timezone to CEST.  I've left the
machine running for several hours, and the time continues to update,
but ever jumps forward those 6 hours.  Running 'date' does show the
correct time, as does running 'system-config-date' again, so just
appears to be a problem with the applet display refreshing. 
Restarting X does appear to resolve the problem.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mark McLoughlin 2004-09-29 05:44:44 EDT
4 year old upstream bug:

  http://bugzilla.gnome.org/show_bug.cgi?id=19197
Comment 2 Mark McLoughlin 2004-09-29 06:18:17 EDT
Okay, turns out this can be trivially fixed in glibc:

  - recently, changes were made to glibc in order to stat() 
    /etc/localtime everytime tzset() is called and re-load
    if the file has changed

  - the actual check to see if the file changed only compares
    the previous st_dev/st_ino to the current one

  - system-config-time truncates and re-writes /etc/localtime
    rather than creating a new file, so the __tzfile_read()
    check doesn't get triggered in this case

  - Jakub agreed that adding an st_mtime check to __tzfile_read()
    makes sense and that should fix the problem
Comment 5 Jakub Jelinek 2004-09-30 05:03:50 EDT
Should be fixed in glibc-2.3.3-60 and above.

Note You need to log in before you can comment on or make changes to this bug.