Bug 1334960 - ValueError: plural forms expression could be dangerous
Summary: ValueError: plural forms expression could be dangerous
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Samantha N. Bueno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4ce8498e0a95be83baa56836001...
Depends On:
Blocks: F24FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2016-05-10 23:16 UTC by Nerijus Baliūnas
Modified: 2016-10-11 14:22 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-11 14:22:03 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (330.21 KB, text/plain)
2016-05-10 23:16 UTC, Nerijus Baliūnas
no flags Details
File: anaconda.log (64.32 KB, text/plain)
2016-05-10 23:16 UTC, Nerijus Baliūnas
no flags Details
File: dnf.log (2.61 KB, text/plain)
2016-05-10 23:16 UTC, Nerijus Baliūnas
no flags Details
File: environ (459 bytes, text/plain)
2016-05-10 23:16 UTC, Nerijus Baliūnas
no flags Details
File: lsblk_output (1.35 KB, text/plain)
2016-05-10 23:16 UTC, Nerijus Baliūnas
no flags Details
File: nmcli_dev_list (1.25 KB, text/plain)
2016-05-10 23:16 UTC, Nerijus Baliūnas
no flags Details
File: os_info (449 bytes, text/plain)
2016-05-10 23:16 UTC, Nerijus Baliūnas
no flags Details
File: program.log (17.66 KB, text/plain)
2016-05-10 23:16 UTC, Nerijus Baliūnas
no flags Details
File: storage.log (30.24 KB, text/plain)
2016-05-10 23:16 UTC, Nerijus Baliūnas
no flags Details
File: syslog (68.60 KB, text/plain)
2016-05-10 23:16 UTC, Nerijus Baliūnas
no flags Details
File: ifcfg.log (2.41 KB, text/plain)
2016-05-10 23:16 UTC, Nerijus Baliūnas
no flags Details
File: packaging.log (613 bytes, text/plain)
2016-05-10 23:17 UTC, Nerijus Baliūnas
no flags Details

Description Nerijus Baliūnas 2016-05-10 23:16:37 UTC
Description of problem:
Choose Lithuanian language and choose disks (partitioning).

Version-Release number of selected component:
anaconda-24.13.4-1

The following was filed automatically by anaconda:
anaconda 24.13.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/gettext.py", line 76, in c2py
    raise ValueError('plural forms expression could be dangerous')
  File "/usr/lib64/python3.5/gettext.py", line 297, in _parse
    self.plural = c2py(plural)
  File "/usr/lib64/python3.5/gettext.py", line 162, in __init__
    self._parse(fp)
  File "/usr/lib64/python3.5/gettext.py", line 426, in translation
    t = _translations.setdefault(key, class_(fp))
  File "/usr/lib/python3.5/site-packages/blivet/i18n.py", line 37, in _get_translations
    _cached_translations[lc_messages] = gettext.translation("blivet", fallback=True)
  File "/usr/lib/python3.5/site-packages/blivet/i18n.py", line 51, in <lambda>
    _ = lambda x: _get_translations().gettext(x) if x != "" else ""
  File "/usr/lib/python3.5/site-packages/blivet/size.py", line 107, in _makeSpec
    word = (_(prefix) + _(suffix))
  File "/usr/lib/python3.5/site-packages/blivet/size.py", line 433, in humanReadable
    return retval_str + " " + _makeSpec(unit.abbr, _BYTES_SYMBOL, xlate, lowercase=False)
  File "/usr/lib/python3.5/site-packages/blivet/size.py", line 286, in _toString
    return self.humanReadable()
  File "/usr/lib/python3.5/site-packages/blivet/size.py", line 289, in __str__
    return stringize(self._toString())
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 659, in _add_disk_overview
    str(disk.size),
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 574, in refresh
    self._add_disk_overview(disk, self.local_disks_box)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 378, in _on_spoke_clicked
    spoke.refresh()
ValueError: plural forms expression could be dangerous

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-S-dvd-x86_64-24 quiet
dnf.rpm.log:    May 10 23:11:21 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.5.2-302.fc24.x86_64
product:        Fedora
release:        Cannot get release name.
reproducible:   Not sure how to reproduce the problem
type:           anaconda
version:        24

Comment 1 Nerijus Baliūnas 2016-05-10 23:16:42 UTC
Created attachment 1155900 [details]
File: anaconda-tb

Comment 2 Nerijus Baliūnas 2016-05-10 23:16:44 UTC
Created attachment 1155901 [details]
File: anaconda.log

Comment 3 Nerijus Baliūnas 2016-05-10 23:16:46 UTC
Created attachment 1155902 [details]
File: dnf.log

Comment 4 Nerijus Baliūnas 2016-05-10 23:16:47 UTC
Created attachment 1155903 [details]
File: environ

Comment 5 Nerijus Baliūnas 2016-05-10 23:16:48 UTC
Created attachment 1155904 [details]
File: lsblk_output

Comment 6 Nerijus Baliūnas 2016-05-10 23:16:50 UTC
Created attachment 1155905 [details]
File: nmcli_dev_list

Comment 7 Nerijus Baliūnas 2016-05-10 23:16:51 UTC
Created attachment 1155906 [details]
File: os_info

Comment 8 Nerijus Baliūnas 2016-05-10 23:16:53 UTC
Created attachment 1155907 [details]
File: program.log

Comment 9 Nerijus Baliūnas 2016-05-10 23:16:55 UTC
Created attachment 1155908 [details]
File: storage.log

Comment 10 Nerijus Baliūnas 2016-05-10 23:16:57 UTC
Created attachment 1155909 [details]
File: syslog

Comment 11 Nerijus Baliūnas 2016-05-10 23:16:58 UTC
Created attachment 1155910 [details]
File: ifcfg.log

Comment 12 Nerijus Baliūnas 2016-05-10 23:17:00 UTC
Created attachment 1155911 [details]
File: packaging.log

Comment 13 Nerijus Baliūnas 2016-05-10 23:20:49 UTC
Choosing English works OK.

Comment 14 David Shea 2016-05-11 12:47:30 UTC
Someone with permissions in Zanata needs to fix the Plural-Forms headers (s/or/||/) and push lt.po back to zanata.

Comment 15 Brian Lane 2016-05-12 23:44:44 UTC
I tried. Zanata is not cooperating and I cannot find where that gets set on the server side.

zanata push  --push-type target --lang lt

...

[ERROR] Can not find the lt translation for blivet

po/lt.po exists, and I get the same error if I add --srcdir ./po/

Comment 16 Nerijus Baliūnas 2016-05-27 21:45:13 UTC
Will it be fixed, because Final Freeze is coming?

Comment 17 Fedora Blocker Bugs Application 2016-05-27 21:50:34 UTC
Proposed as a Blocker for 24-final by Fedora user nerijus using the blocker tracking app because:

 Cannot use Lithuanian language in installer. Seems to be quite easy to fix.

Comment 18 Geoffrey Marr 2016-05-30 18:23:35 UTC
Discussed during the 2016-05-30 blocker review meeting: [1]

Decision was made to not classify this a blocker as the locale that this bug affects is not large enough to block release on. It is however, big enough to warrant a freeze exception.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-05-30/f24-blocker-review.2016-05-30-16.01.txt

Comment 19 Fedora Blocker Bugs Application 2016-05-30 21:44:54 UTC
Proposed as a Freeze Exception for 24-final by Fedora user nerijus using the blocker tracking app because:

 Lithuanian cannot be used in installer, and it seems to be quite easy to fix.

Comment 20 Brian Lane 2016-05-31 15:25:14 UTC
Looks like lt.po is now correct. Uses || instead of 'or' in the Plural-Forms

Comment 21 Nerijus Baliūnas 2016-05-31 20:00:55 UTC
Is there a test iso image which I can test?

Comment 22 Adam Williamson 2016-05-31 21:03:02 UTC
brian: don't we need a new package build of blivet for this to be 'ON_QA'?

Comment 23 Brian Lane 2016-05-31 22:05:21 UTC
Yes, sorry about that.

Comment 24 Nerijus Baliūnas 2016-06-21 14:35:07 UTC
Unfortunately it was not fixed for the final F24 release.

Comment 25 Adam Williamson 2016-06-21 14:44:52 UTC
yeah, we never did get a new build of blivet, not sure why not :(

Comment 26 Nerijus Baliūnas 2016-10-11 14:22:03 UTC
Works on F25 beta.


Note You need to log in before you can comment on or make changes to this bug.