Bug 1335046 - TypeError: Argument 0 does not allow None as a value
Summary: TypeError: Argument 0 does not allow None as a value
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 24
Hardware: s390x
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Samantha N. Bueno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Keywords:
Depends On:
Blocks: ZedoraTracker F25FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2016-05-11 08:44 UTC by Jan Stodola
Modified: 2016-11-15 13:33 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-15 13:33:10 UTC


Attachments (Terms of Use)

Description Jan Stodola 2016-05-11 08:44:07 UTC
Description of problem:
There is a traceback when asking anaconda to add a zFCP LUN without entering any value for the device number/WWPN/LUN:

anaconda 24.13.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/gi/overrides/BlockDev.py", line 399, in wrapped
    ret = orig_obj(*args, **kwargs)
  File "/usr/lib/python3.5/site-packages/blivet/zfcp.py", line 55, in __init__
    self.devnum = blockdev.s390.sanitize_dev_input(devnum)
  File "/usr/lib/python3.5/site-packages/blivet/zfcp.py", line 340, in addFCP
    d = ZFCPDevice(devnum, wwpn, fcplun)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/advstorage/zfcp.py", line 147, in _discover
    self.zfcp.addFCP(args[0], args[1], args[2])
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/advstorage/zfcp.py", line 113, in on_start_clicked
    self._discover(device, wwpn, lun)
TypeError: Argument 0 does not allow None as a value


Version-Release number of selected component (if applicable):
python-blivet-1.20.1-1.fc24
anaconda-24.13.4-1.fc24

How reproducible:
always

Steps to Reproduce:
1. proceed to the Installation Destination spoke
2. click "Add a disk..."
3. click "Add zFCP LUN..."
4. click "Start Discovery" without entering any value

Actual results:
traceback

Expected results:
warning or error message, but being able to continue with the installation

Comment 2 Jan Stodola 2016-05-11 08:49:12 UTC
Similar issue in case of adding DASD without entering a device number:

anaconda 24.13.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/gi/overrides/BlockDev.py", line 399, in wrapped
    ret = orig_obj(*args, **kwargs)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/advstorage/dasd.py", line 135, in _discover
    blockdev.s390.dasd_online(device)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/advstorage/dasd.py", line 103, in on_start_clicked
    self._discover(device)
TypeError: Argument 0 does not allow None as a value

Comment 3 Samantha N. Bueno 2016-11-01 20:32:07 UTC
https://github.com/rhinstaller/anaconda/pull/857 should fix the issues with manually adding DASDs and zFCP devices.

Comment 4 Fedora Blocker Bugs Application 2016-11-02 19:44:44 UTC
Proposed as a Freeze Exception for 25-final by Fedora user sbueno using the blocker tracking app because:

 An s390x bug which causes a traceback if a user passes no input when trying to manually add zFCP devices or DASDs in the advanced storage spoke. The fix for this is simple and isolated to s390x-specific code.

Comment 5 Fedora Update System 2016-11-07 23:31:33 UTC
anaconda-25.20.7-1.fc25 python-blivet-2.1.6-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-91844f4982

Comment 6 Geoffrey Marr 2016-11-08 00:57:46 UTC
Discussed during the 2016-11-07 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException was made as this fixes a significant issue for s390x users and the fix is limited to s390-specific code so cannot affect primary arches.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-11-07/f25-blocker-review.2016-11-07-17.01.txt

Comment 7 Fedora Update System 2016-11-09 02:26:23 UTC
anaconda-25.20.8-1.fc25, python-blivet-2.1.6-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-91844f4982

Comment 8 Fedora Update System 2016-11-15 13:33:10 UTC
anaconda-25.20.8-1.fc25, python-blivet-2.1.6-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.