Bug 1335119 - Invalid CPU-related output
Summary: Invalid CPU-related output
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sysstat
Version: 6.7
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Michal Sekletar
QA Contact: BaseOS QE - Apps
URL: https://github.com/sysstat/sysstat/is...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-11 12:07 UTC by Bryan Harris
Modified: 2016-06-22 11:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-22 11:29:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Bryan Harris 2016-05-11 12:07:02 UTC
Description of problem:

Same issue as described in URL below.  No answer given to the actual question of the tens of thousands.  They describe as "counters somewhere have overflown" but no fix or instructions shown for how to deal with that type of situation.

https://github.com/sysstat/sysstat/issues/8

Version-Release number of selected component (if applicable):

sysstat-9.0.4-27.el6.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Run CPU-intensive jobs (in our case oracle)
2. Run pidstat for a few hours
3. Reports have occurrences of impossibly-high resources

Actual results:

Example command:

for i in `seq 1 24`; do
  /usr/bin/pidstat -duhIl 30 118 >> $_filename
done

Report output:

1462942863     32714 4847.07 1792.37    0.00 1678.60     0  23596.53      0.00      0.00  oraclepldsc (LOCAL=NO)

Expected results:

System has only 4x CPUs, so I would expect 6th column to be max 400%, but since we have -I option I would not expect more than 100%.  This is not explained in the FAQ section 4.4.  We are also dividing by total # CPUs with the -I option.

Additional info:

This happens every time we use pidstat.

Comment 1 Peter Schiffer 2016-05-11 12:21:44 UTC
Bryan,

this issue should be fixed in RHEL-6.8 with sysstat-9.0.4-31.el6; we backported following patch: https://github.com/sysstat/sysstat/issues/73

peter

Comment 3 Bryan Harris 2016-05-11 14:07:59 UTC
Thanks that's very good news.


Note You need to log in before you can comment on or make changes to this bug.