Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1335138 - [Bug] Unable to save host due to 'some of the interfaces are invalid' error
Summary: [Bug] Unable to save host due to 'some of the interfaces are invalid' error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Fact
Version: 6.1.8
Hardware: All
OS: Linux
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-11 12:23 UTC by Kamudini Gazdikova
Modified: 2020-01-17 15:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-06 18:28:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 11442 0 Normal New When host is created from facts we don't trigger validations 2020-06-02 12:53:52 UTC

Description Kamudini Gazdikova 2016-05-11 12:23:36 UTC
Description of problem:
Unable to save host due to 'some of the interfaces are invalid' error

Version-Release number of selected component (if applicable):
Red Hat Satellite v 6.1.8

Issue:

Customer is unable to delete "virbr0_nic" interfaces that were detected by satellite. 

It created 2 conflicting entries, and customer is unable to update host unless the conflicting interfaces are being fixed.

Trying to delete one or all the entries, it gives error " Some of the interfaces are invalid. Please check the table below."


Additional info:

Cloned from the upstream bug http://projects.theforeman.org/issues/11251

Comment 1 Bryan Kearney 2016-05-11 14:16:47 UTC
Upstream bug assigned to mhulan@redhat.com

Comment 2 Bryan Kearney 2016-05-11 14:16:48 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11251 has been closed

Comment 3 Marek Hulan 2016-05-11 14:47:32 UTC
The actual cause is tracked by different redmine issue.

Comment 4 Bryan Kearney 2016-05-11 16:17:52 UTC
Upstream bug component is Fact

Comment 7 Marek Hulan 2016-12-02 12:25:27 UTC
Ranjan, I see you are active in the CC. I've got some updates.

Alternative solution to fix the root cause is upstream issue 7344 that was already present in Satellite 6.1. Was this customer previously using 6.0? If that's the case I think we can consider the root cause as fixed.

Also the result of original cause seems to be solved via bz 1268207 which was delieverd in 6.2.

Last workaround that could probably be used is to delete the interface through direct interfaces API. E.g. to delete interface with id 36 on host client.example.com one could run this

> curl  -H "Content-Type:application/json" -H "Accept:application/json" https://admin:changeme@satellite.example.com/api/v2/hosts/client.example.com/interfaces/36 -X DELETE

to get ids of interfaces for a given host you can use

> curl  -H "Content-Type:application/json" -H "Accept:application/json" https://admin:changeme@satellite.example.com/api/v2/hosts/client.example.com/interfaces -X DELETE

Ranjan, could you please confirm with the customer and let us know whether we can close the BZ?

Comment 8 Ranjan Kumar 2016-12-06 05:18:50 UTC
Hello Marek, Confirmed with customer you can close this BZ.

Comment 9 Marek Hulan 2016-12-06 18:28:59 UTC
Thanks for letting us know. Closing.


Note You need to log in before you can comment on or make changes to this bug.