Bug 1335183 - [abrt] kinfocenter: qt_message_fatal(): kinfocenter killed by SIGABRT [NEEDINFO]
Summary: [abrt] kinfocenter: qt_message_fatal(): kinfocenter killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1174257
Alias: None
Product: Fedora
Classification: Fedora
Component: kinfocenter
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:796004a6664118797efb989d133...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-11 13:43 UTC by Alvin
Modified: 2016-05-11 13:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-11 13:48:54 UTC
rdieter: needinfo? (alvin)


Attachments (Terms of Use)
File: backtrace (22.67 KB, text/plain)
2016-05-11 13:43 UTC, Alvin
no flags Details
File: cgroup (336 bytes, text/plain)
2016-05-11 13:43 UTC, Alvin
no flags Details
File: core_backtrace (5.03 KB, text/plain)
2016-05-11 13:43 UTC, Alvin
no flags Details
File: dso_list (14.91 KB, text/plain)
2016-05-11 13:43 UTC, Alvin
no flags Details
File: environ (2.30 KB, text/plain)
2016-05-11 13:43 UTC, Alvin
no flags Details
File: limits (1.29 KB, text/plain)
2016-05-11 13:43 UTC, Alvin
no flags Details
File: maps (66.18 KB, text/plain)
2016-05-11 13:43 UTC, Alvin
no flags Details
File: mountinfo (3.87 KB, text/plain)
2016-05-11 13:43 UTC, Alvin
no flags Details
File: namespaces (85 bytes, text/plain)
2016-05-11 13:43 UTC, Alvin
no flags Details
File: open_fds (140 bytes, text/plain)
2016-05-11 13:43 UTC, Alvin
no flags Details
File: proc_pid_status (1.10 KB, text/plain)
2016-05-11 13:43 UTC, Alvin
no flags Details
File: var_log_messages (314 bytes, text/plain)
2016-05-11 13:43 UTC, Alvin
no flags Details

Description Alvin 2016-05-11 13:43:09 UTC
Description of problem:
Use 'ssh -X' to log in and run kinfocenter:

$ kinfocenter
"KConfigIni: In file /usr/share/applications/fedora-release-notes.webapp.desktop, line 7: " "Invalid escape sequence \"\\\"\"."
"KConfigIni: In file /usr/share/applications/fedora-release-notes.webapp.desktop, line 7: " "Invalid escape sequence \"\\$\"."
"KConfigIni: In file /usr/share/applications/fedora-release-notes.webapp.desktop, line 7: " "Invalid escape sequence \"\\\"\"."
"KConfigIni: In file /usr/share/applications/fedora-release-notes.webapp.desktop, line 7: " "Invalid escape sequence \"\\$\"."
"KConfigIni: In file /usr/share/applications/fedora-release-notes.webapp.desktop, line 7: " "Invalid escape sequence \"\\$\"."
"KConfigIni: In file /usr/share/applications/fedora-release-notes.webapp.desktop, line 7: " "Invalid escape sequence \"\\$\"."
"KConfigIni: In file /usr/share/applications/fedora-release-notes.webapp.desktop, line 7: " "Invalid escape sequence \"\\$\"."
"KConfigIni: In file /usr/share/applications/fedora-release-notes.webapp.desktop, line 7: " "Invalid escape sequence \"\\$\"."
^C

Break with <CTRL+C> because nothing happens. kinfocenter does not start.

Version-Release number of selected component:
kinfocenter-5.6.3-1.fc24

Additional info:
reporter:       libreport-2.7.0
backtrace_rating: 4
cmdline:        kinfocenter
crash_function: qt_message_fatal
executable:     /usr/bin/kinfocenter
global_pid:     2930
kernel:         4.5.3-300.fc24.x86_64
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            1001

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 qt_message_fatal at global/qlogging.cpp:1610
 #3 QMessageLogger::fatal at global/qlogging.cpp:784
 #4 QXcbConnection::QXcbConnection at qxcbconnection.cpp:581
 #5 QXcbIntegration::QXcbIntegration at qxcbintegration.cpp:177
 #6 QXcbIntegrationPlugin::create at qxcbmain.cpp:50
 #7 loadIntegration at kernel/qplatformintegrationfactory.cpp:56
 #8 QPlatformIntegrationFactory::create at kernel/qplatformintegrationfactory.cpp:73
 #9 init_platform at kernel/qguiapplication.cpp:1053
 #10 QGuiApplicationPrivate::createPlatformIntegration at kernel/qguiapplication.cpp:1222
 #11 QGuiApplicationPrivate::createEventDispatcher at kernel/qguiapplication.cpp:1239

Comment 1 Alvin 2016-05-11 13:43:15 UTC
Created attachment 1156155 [details]
File: backtrace

Comment 2 Alvin 2016-05-11 13:43:16 UTC
Created attachment 1156156 [details]
File: cgroup

Comment 3 Alvin 2016-05-11 13:43:17 UTC
Created attachment 1156157 [details]
File: core_backtrace

Comment 4 Alvin 2016-05-11 13:43:19 UTC
Created attachment 1156158 [details]
File: dso_list

Comment 5 Alvin 2016-05-11 13:43:20 UTC
Created attachment 1156159 [details]
File: environ

Comment 6 Alvin 2016-05-11 13:43:21 UTC
Created attachment 1156160 [details]
File: limits

Comment 7 Alvin 2016-05-11 13:43:23 UTC
Created attachment 1156161 [details]
File: maps

Comment 8 Alvin 2016-05-11 13:43:24 UTC
Created attachment 1156162 [details]
File: mountinfo

Comment 9 Alvin 2016-05-11 13:43:25 UTC
Created attachment 1156163 [details]
File: namespaces

Comment 10 Alvin 2016-05-11 13:43:27 UTC
Created attachment 1156164 [details]
File: open_fds

Comment 11 Alvin 2016-05-11 13:43:28 UTC
Created attachment 1156165 [details]
File: proc_pid_status

Comment 12 Alvin 2016-05-11 13:43:29 UTC
Created attachment 1156166 [details]
File: var_log_messages

Comment 13 Rex Dieter 2016-05-11 13:47:46 UTC
try instead (on the remote end):

LIBGL_DRI3_DISABLE=1 konsole

Comment 14 Rex Dieter 2016-05-11 13:48:54 UTC
marking as dup of bug #1174257

*** This bug has been marked as a duplicate of bug 1174257 ***


Note You need to log in before you can comment on or make changes to this bug.