Bug 1335196 - Kernel modules for sound device on Intel Bay Trail SoC are missing
Summary: Kernel modules for sound device on Intel Bay Trail SoC are missing
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-11 14:33 UTC by Dominik Drazyk
Modified: 2016-08-15 01:46 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-12 15:54:49 UTC
Type: Bug


Attachments (Terms of Use)

Description Dominik Drazyk 2016-05-11 14:33:18 UTC
Description of problem:
There are no kernel modules for sound device on Intel Bay Trail SoC. These modules are available in Fedora 23. Kernel is missing below options: CONFIG_SND_SOC_INTEL_BAYTRAIL=m
CONFIG_SND_SOC_INTEL_BYT_MAX98090_MACH=m 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 24 on bay trail hardware (for example Toshiba Chromebook 2)


Actual results:
No sound device available.

Expected results:
Sound device available.

Additional info:
HDMI sound device works fine. Only speakers are unavailable.

Comment 1 lhs 2016-08-10 04:12:35 UTC
kernel module snd-soc-sst-byt-max98090-mach.ko.xz was found in /usr/lib/modules/4.4.9-300.fc23.x86_64/kernel/sound/soc/intel/boards/.

But not in /usr/lib/modules/4.6.4-301.fc24.x86_64/kernel/sound/soc/intel/boards/.

Comment 2 Laura Abbott 2016-08-10 17:21:57 UTC
Can you share alsa-info.sh from the working and non-working case? I think that driver is supposed to be deprecated in favor of another driver but I can't tell what the replacement driver is supposed to be.

Comment 4 Laura Abbott 2016-08-12 15:54:49 UTC
Unfortunately it looks like the decision was made to not support this module in a distro like environment http://marc.info/?l=linux-kernel&m=147095830801834 . I'm going to close this as CANTFIX unless the Intel developers decide to change their mind or someone reverts it.


Note You need to log in before you can comment on or make changes to this bug.