Bug 133522 - Cannot netboot hosts with dhcp 3.0.1-8
Summary: Cannot netboot hosts with dhcp 3.0.1-8
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-24 16:47 UTC by Jason Tibbitts
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: dhcp-3.0.1-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 14:35:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Packet capture from 3.0.1-8 server showing bad response. (4.93 KB, text/plain)
2004-09-24 16:49 UTC, Jason Tibbitts
no flags Details
Packet capture from 3.0.1rc14-1 server showing good response. (4.96 KB, text/plain)
2004-09-24 16:51 UTC, Jason Tibbitts
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:566 normal SHIPPED_LIVE Updated dhcp and dhclient packages 2005-05-26 04:00:00 UTC

Description Jason Tibbitts 2004-09-24 16:47:56 UTC
Under the stock FC2 release of dhcp (3.0.1rc14-1), I can use a stanza
like this:

host netinstall {
    hardware ethernet   00:0d:87:00:95:e2;

    option domain-name  "math.uh.edu";
    option subnet-mask  255.255.255.0;
    option routers      129.7.128.254;

    fixed-address       129.7.128.251;
    next-server         129.7.128.34;
    filename            "/pxelinux.0";
}

to boot a host over the network.  But under the current rawhide
release (3.0.1-8) this doesn't work.  Reverting to the older version
(without making any changes to the configuration file) fixes the
problem.  I will attach two short packet captures showing a request
and a response from each server.  The responses are basically the
same, but with 3.0.1-8 the "next-server" and "filename" options seem
to be ignored.

Unfortunately you folks kindly pushed 3.0.1-8 out for me because it
fixes another rather serious bug.

Comment 1 Jason Tibbitts 2004-09-24 16:49:25 UTC
Created attachment 104272 [details]
Packet capture from 3.0.1-8 server showing bad response.

Comment 2 Jason Tibbitts 2004-09-24 16:51:03 UTC
Created attachment 104273 [details]
Packet capture from 3.0.1rc14-1 server showing good response.

Comment 3 Jason Vas Dias 2004-09-27 18:38:34 UTC
Yes, you are quite correct - dhcp-3.0.1-8 seems to be sending a 
DHCPOFFER that is not accepted by the PXE Boot client . 
I am now investigating and will solve as #1 priority.


Comment 4 Jason Vas Dias 2004-09-27 21:34:08 UTC
I have found a bug fix for this problem .  It was caused by the 
piece of old code that was exercised by the patch from ISC for 
bug #131212, that rejected a host match if it had a "fixed-address".
I've now made it accept such hosts, but both I and the DHCP 
developers are continuing to search for a more satisfactory fix
for bug #131212. 
You can download the new dhcp-3.0.1-9 release, with the temporary
fix applied (that does work, and does not cause 131212 to reappear)
from:
 http://people.redhat.com/~jvdias/DHCP/3.0.1-9
You can build the srpm with:
  rpmbuild --rebuild dhcp-3.0.1-9.src.rpm
or install the binaries compiled for FC2 from the "FC2" subdirectory.

 

Comment 5 Jason Vas Dias 2004-09-28 14:35:28 UTC
A better fix for both bug 131212 and this bug has been found and
incorporated into dhcp-3.0.1-9, now submitted to FC3 and compiled
for FC2 at:
  http://people.redhat.com/~jvdias/DHCP/3.0.1-9
I have tested :
1. Defining a group of hosts with 'deny booting' defined
2. Defining one 'host b { ... }' with a 'filename' parameter
One of the hosts with deny booting tries to get a lease and gets
'booting disallowed' error
Then the host with the filename entry does a PXE Boot and obtains
a lease and the boot file OK.
This now appears to be fixed.
Testing of this new dhcp-3.0.1-9 release on a large busy subnet
would be appreciated.

Comment 6 Jason Tibbitts 2004-10-07 15:00:07 UTC
A week of testing has shown this version to be stable.  However, I see
that 3.0.1-11 has hit rawhide today so I will test it as well.

Comment 7 Jason Vas Dias 2004-10-07 15:24:14 UTC
Many thanks for your help in testing DHCP.
I implemented the fix in dhcp-3.0.1-9; then, in consultation with the
ISC developers, I made some cosmetic changes in dhcp-3.0.1-10; then,
yesterday ISC released dhcp-3.0.2b1, which contained a fix missing from
dhcp-3.0.1-10.
So now dhcp-3.0.1-11 contains the full fix as implemented in ISC DHCP
3.0.2 - I hope it works well for you!
 

Comment 8 Jason Vas Dias 2004-10-07 15:25:36 UTC
P.S. - the dhcp-3.0.1-11 srpm and binary RPMS compiled for FC2 are at:
http://people.redhat.com/~jvdias/DHCP/FC2 


Comment 9 John Flanagan 2004-12-21 19:41:45 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-566.html



Note You need to log in before you can comment on or make changes to this bug.