Bug 1335227 - libglusterfs: clang compile warnings in default-args.c
Summary: libglusterfs: clang compile warnings in default-args.c
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-11 15:32 UTC by Kaleb KEITHLEY
Modified: 2018-08-29 03:35 UTC (History)
1 user (show)

Fixed In Version: glusterfs-4.1.3 (or later)
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-29 03:35:41 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2016-05-11 15:32:59 UTC
Description of problem:

  CC       libglusterfs_la-default-args.lo
default-args.c:1575:20: warning: address of 'args->loc' will always evaluate to 'true' [-Wpointer-bool-conversion]
        if (&args->loc)
        ~~   ~~~~~~^~~
default-args.c:1578:20: warning: address of 'args->loc2' will always evaluate to 'true' [-Wpointer-bool-conversion]
        if (&args->loc2)
        ~~   ~~~~~~^~~~




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anuradha 2016-08-09 07:02:50 UTC
Sent as part of http://review.gluster.org/#/c/15010/

Comment 3 Amar Tumballi 2018-08-29 03:35:41 UTC
This update is done in bulk based on the state of the patch and the time since last activity. If the issue is still seen, please reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.