Bug 133526 - X server hangs entire system with FC3t2 SMP kernel
X server hangs entire system with FC3t2 SMP kernel
Status: CLOSED DUPLICATE of bug 138108
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-09-24 13:03 EDT by John Dennis
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (46.06 KB, text/plain)
2004-09-24 13:07 EDT, John Dennis
no flags Details
output of /proc/cpuinfo (433 bytes, text/plain)
2004-09-24 13:08 EDT, John Dennis
no flags Details

  None (edit)
Description John Dennis 2004-09-24 13:03:42 EDT
Using the FC3t2 SMP kernel on a HP xw4100 workstation with a P4 dual
hyper-threaded CPU the X server will cause the machine to lock up.

To reproduce, boot the smp kernel, at the graphical login prompt log
in, within a few seconds as the Gnome desktop is coming up the system
will hang.

I have not been able to ascertain if there was a machine check or if
the kernel is deadlocked somehow. Alternate consoles do not work,
alt-sysrq to break into the kernel does not work and the machine does
not respond to pings.

The non-smp kernel works fine. If the X server is not started on the
smp kernel hangs do not occur.

The graphics card is a Radeon 7000 using the standard Xorg open source
ATI radeon driver. Attached is the output of /proc/cpu/info and the X
log from a non-smp session.

This system is located in my cube in the Westord office.
Comment 1 John Dennis 2004-09-24 13:07:14 EDT
Created attachment 104274 [details]
Xorg log file

This is the X server log file from a non-smp invocation. Its the smp kernel
that is causing the problem but the two log files should be identical as I do
not believe there is anything in the X server which is dependent on the number
of cpu's or smp.
Comment 2 John Dennis 2004-09-24 13:08:15 EDT
Created attachment 104275 [details]
output of /proc/cpuinfo
Comment 3 John Dennis 2004-09-24 13:10:32 EDT
The cpuinfo is also from a non-smp kernel so it only shows one cpu. If
its important I can get both log files from a smp run.
Comment 4 Mike A. Harris 2004-10-16 18:30:09 EDT
(II) Initializing built-in extension COMPOSITE

If you disable COMPOSITE does the problem still occur?  I assume
so, but just curious.  ;)
Comment 5 Kristian Høgsberg 2004-11-16 15:40:00 EST
Probably a duplicate of bug #138108.
Comment 6 Kristian Høgsberg 2004-11-23 17:35:19 EST
This is most likely a dupe of bug #138108, for which I believe we now
have a fix.  xorg-x11-6.8.1-17 or later in rawhide should make the
crashes go away, and we'll be putting out an update shortly for FC3. 
Please test either the udpate or the rawhide packages so we can
confirm that this is indeed the same issue.  Thanks.
Comment 7 Kristian Høgsberg 2004-11-23 17:35:54 EST

*** This bug has been marked as a duplicate of 138108 ***
Comment 8 Red Hat Bugzilla 2006-02-21 14:05:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.