Bug 1335295 - `hammer host-collection hosts` command is undefined
Summary: `hammer host-collection hosts` command is undefined
Keywords:
Status: CLOSED DUPLICATE of bug 1317677
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-11 19:44 UTC by Andrew Kofink
Modified: 2016-09-20 01:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-07 10:03:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 15290 None None None 2016-06-03 18:01:52 UTC

Description Andrew Kofink 2016-05-11 19:44:03 UTC
Description of problem:
[vagrant@sat-test-rhel7 ~]$ hammer host-collection hosts
Error: The server does not support such operation.

Version-Release number of selected component (if applicable):
satellite-6.2.0-10.0.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. run `hammer host-collection hosts`

Actual results:
Error: The server does not support such operation.

Expected results:
hammer host-collection hosts --id 1
Something like this:
---|----------------------------|------------------|------------|----------------|------------------
ID | NAME                       | OPERATING SYSTEM | HOST GROUP | IP             | MAC              
---|----------------------------|------------------|------------|----------------|------------------
1  | sat-test-rhel7.example.com | RedHat 7.2       |            | 192.168.121.97 | 52:54:00:33:5e:4e
---|----------------------------|------------------|------------|----------------|------------------


Additional info:

Comment 1 Andrew Kofink 2016-05-11 20:39:12 UTC
This bug also exists in katello-devel and Satellite 6.1.8

Comment 2 Andrew Kofink 2016-06-03 17:29:07 UTC
Created redmine issue http://projects.theforeman.org/issues/15290 from this bug

Comment 4 Brad Buckingham 2016-06-07 10:03:33 UTC

*** This bug has been marked as a duplicate of bug 1317677 ***


Note You need to log in before you can comment on or make changes to this bug.