Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1335314 - [RH Ceph 2.0] ceph-ansible with mds node fails during ceph --version
Summary: [RH Ceph 2.0] ceph-ansible with mds node fails during ceph --version
Keywords:
Status: CLOSED DUPLICATE of bug 1336571
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-ansible
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Christina Meno
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-11 21:51 UTC by Vasu Kulkarni
Modified: 2016-05-18 20:31 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-18 20:31:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vasu Kulkarni 2016-05-11 21:51:56 UTC
Description of problem:

Have following playbook:
2  Monitors
1 MDS
2 OSD server ( 2x3 devices)


Full Logs:
http://magna002.ceph.redhat.com/vasu-2016-05-11_11:33:39-smoke:ceph-ansible-master---basic-clara/230938/teuthology.log


when running this it fails during following task
TASK: [ceph.ceph-common | install rados gateway vhost] ************************ 
skipping: [clara006.ceph.redhat.com]

TASK: [ceph.ceph-common | enable rados gateway vhost and disable default site] *** 
skipping: [clara006.ceph.redhat.com] => (item=a2ensite rgw.conf)
skipping: [clara006.ceph.redhat.com] => (item=a2dissite *default)

TASK: [ceph.ceph-common | install s3gw.fcgi script] *************************** 
skipping: [clara006.ceph.redhat.com]

TASK: [ceph.ceph-common | get ceph version] *********************************** 
failed: [clara006.ceph.redhat.com] => {"changed": false, "cmd": "ceph --version", "failed": true, "rc": 2}
msg: [Errno 2] No such file or directory

FATAL: all hosts have already failed -- aborting

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/home/ubuntu/site.retry

clara006.ceph.redhat.com   : ok=22   changed=1    unreachable=0    failed=1   
clara007.ceph.redhat.com   : ok=85   changed=13   unreachable=0    failed=0   
clara008.ceph.redhat.com   : ok=157  changed=10   unreachable=0    failed=0   
clara010.ceph.redhat.com   : ok=157  changed=10   unreachable=0    failed=0   
clara011.ceph.redhat.com   : ok=85   changed=13   unreachable=0    failed=0   


2016-05-11T16:15:45.123 ERROR:teuthology.task.ceph_ansible:Failed during ansible execution


TASK: [ceph.ceph-common | install s3gw.fcgi script] *************************** 
skipping: [clara006.ceph.redhat.com]

TASK: [ceph.ceph-common | get ceph version] *********************************** 
failed: [clara006.ceph.redhat.com] => {"changed": false, "cmd": "ceph --version", "failed": true, "rc": 2}
msg: [Errno 2] No such file or directory

FATAL: all hosts have already failed -- aborting

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/home/ubuntu/site.retry

clara006.ceph.redhat.com   : ok=22   changed=1    unreachable=0    failed=1   
clara007.ceph.redhat.com   : ok=85   changed=13   unreachable=0    failed=0   
clara008.ceph.redhat.com   : ok=157  changed=10   unreachable=0    failed=0   
clara010.ceph.redhat.com   : ok=157  changed=10   unreachable=0    failed=0   
clara011.ceph.redhat.com   : ok=85   changed=13   unreachable=0    failed=0

Comment 2 Ken Dreyer (Red Hat) 2016-05-11 21:58:02 UTC
I logged into clara006, and no ceph packages are installed there, so that's why ceph --version fails.

Comment 3 Andrew Schoen 2016-05-11 22:05:07 UTC
I think we need the commits from this upstream PR, we're not installing the ceph-mds package.

https://github.com/ceph/ceph-ansible/pull/763

Comment 5 Ken Dreyer (Red Hat) 2016-05-18 20:31:29 UTC

*** This bug has been marked as a duplicate of bug 1336571 ***


Note You need to log in before you can comment on or make changes to this bug.