Bug 1335392 - i686 kernels 4.5.3 and 4.5.4 fail to boot due to i915 issue (regression) on Diamondville with 945GME
Summary: i686 kernels 4.5.3 and 4.5.4 fail to boot due to i915 issue (regression) on D...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 23
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1303860 1335173
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-12 07:24 UTC by David H. Gutteridge
Modified: 2016-05-26 05:21 UTC (History)
8 users (show)

Fixed In Version: kernel-4.5.5-200.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-26 05:21:27 UTC
Type: Bug


Attachments (Terms of Use)

Description David H. Gutteridge 2016-05-12 07:24:41 UTC
Description of problem:
4.5.3 and 4.5.4 kernels for Fedora 23 fail to complete booting on my i686 Diamondville netbook. This is a regression versus the 4.4 series and earlier.

The specific graphics chip in question is:

May 11 21:15:51 arcusvii.nonus-porta.net kernel: agpgart-intel 0000:00:00.0: Intel 945GME Chipset
May 11 21:15:51 arcusvii.nonus-porta.net kernel: agpgart-intel 0000:00:00.0: detected gtt size: 262144K total, 262144K mappable
May 11 21:15:51 arcusvii.nonus-porta.net kernel: agpgart-intel 0000:00:00.0: detected 8192K stolen memory
May 11 21:15:51 arcusvii.nonus-porta.net kernel: agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xc0000000

Version-Release number of selected component (if applicable):

kernel-4.5.3-200.fc23
kernel-4.5.4-200.fc23

How reproducible:
Always

Steps to Reproduce:
1. Boot kernel.
2. Observe it fails to complete, and gives a backtrace.

Actual results:
Hard hang on boot.

Expected results:
Successful boot, as with older kernels.

Additional info:

Trace for 4.5.3:

May 12 01:42:55 arcusvii.nonus-porta.net kernel: ------------[ cut here ]------------
May 12 01:42:55 arcusvii.nonus-porta.net kernel: kernel BUG at include/linux/page-flags.h:272!
May 12 01:42:55 arcusvii.nonus-porta.net kernel: invalid opcode: 0000 [#1] SMP 
May 12 01:42:55 arcusvii.nonus-porta.net kernel: Modules linked in: ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_broute bridge stp llc ebtable_filter ebtable_nat ebtables ip6table_mangle ip6table_security ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_raw ip6table_filter ip6_tables iptable_mangle iptable_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_raw bnep arc4 rtl818x_pci mac80211 uvcvideo btusb videobuf2_vmalloc btrtl iTCO_wdt videobuf2_memops btbcm msi_wmi iTCO_vendor_support videobuf2_v4l2 gpio_ich btintel sparse_keymap videobuf2_core bluetooth videodev coretemp cfg80211 snd_hda_codec_realtek snd_hda_codec_generic media snd_hda_intel snd_hda_codec joydev lpc_ich eeprom_93cx6 snd_hda_core rfkill snd_hwdep snd_seq wmi snd_seq_device
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  snd_pcm snd_timer snd acpi_cpufreq soundcore tpm_tis tpm nfsd auth_rpcgss nfs_acl lockd grace sunrpc dm_crypt i915 i2c_algo_bit drm_kms_helper syscopyarea sysfillrect sysimgblt ata_generic fb_sys_fops serio_raw drm r8169 pata_acpi mii fjes video ums_realtek uas usb_storage
May 12 01:42:55 arcusvii.nonus-porta.net kernel: CPU: 1 PID: 1287 Comm: gnome-shell Not tainted 4.5.3-200.fc23.i686 #1
May 12 01:42:55 arcusvii.nonus-porta.net kernel: Hardware name: LG Electronics X110-L.A7B1A9/X110, BIOS EN021IL1.10I 11/04/2008
May 12 01:42:55 arcusvii.nonus-porta.net kernel: task: e9ace300 ti: e9b1a000 task.ti: e9b1a000
May 12 01:42:55 arcusvii.nonus-porta.net kernel: EIP: 0060:[<f7de2c42>] EFLAGS: 00210282 CPU: 1
May 12 01:42:55 arcusvii.nonus-porta.net kernel: EIP is at drm_pci_alloc+0xc2/0x1b0 [drm]
May 12 01:42:55 arcusvii.nonus-porta.net kernel: EAX: 00000000 EBX: 00040000 ECX: 0000003c EDX: 00000007
May 12 01:42:55 arcusvii.nonus-porta.net kernel: ESI: e9be78b0 EDI: c04092b0 EBP: e9b1bbc0 ESP: e9b1bb9c
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
May 12 01:42:55 arcusvii.nonus-porta.net kernel: CR0: 80050033 CR2: 81aa91a0 CR3: 29b01000 CR4: 000006d0
May 12 01:42:55 arcusvii.nonus-porta.net kernel: Stack:
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  024040c0 00000000 f5012864 f8045688 024040c0 0fa8de4d f6a21c74 f6a21c80
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  00000000 e9b1bbd8 f7fbba5e 00000100 f478e800 e341f300 e341fd80 e9b1bc0c
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  f800200b e9807800 f525c800 00200002 f6183a00 00000000 f680a400 00000000
May 12 01:42:55 arcusvii.nonus-porta.net kernel: Call Trace:
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7fbba5e>] i915_gem_object_attach_phys+0xde/0x170 [i915]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f800200b>] intel_prepare_plane_fb+0x19b/0x2d0 [i915]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7dad3a5>] drm_atomic_helper_prepare_planes+0x45/0xb0 [drm_kms_helper]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7ff9552>] intel_atomic_commit+0x82/0x16d0 [i915]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7ffbb3e>] ? intel_atomic_check+0x3de/0x1110 [i915]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<c05b2075>] ? __kmalloc_track_caller+0x195/0x240
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7ffb760>] ? intel_link_compute_m_n+0x50/0x50 [i915]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7df7ccf>] ? drm_atomic_check_only+0x19f/0x690 [drm]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7df74b2>] ? drm_atomic_get_crtc_state+0x52/0xb0 [drm]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<c057a81a>] ? kmemdup+0x2a/0x40
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7df81f2>] drm_atomic_commit+0x32/0x60 [drm]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7daddac>] drm_atomic_helper_update_plane+0xbc/0x100 [drm_kms_helper]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7de7d89>] __setplane_internal+0x1e9/0x230 [drm]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7de7f4e>] drm_mode_cursor_common+0x17e/0x3a0 [drm]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7dec2f0>] ? drm_mode_cursor_ioctl+0x70/0x70 [drm]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7dec2fd>] drm_mode_cursor2_ioctl+0xd/0x10 [drm]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7ddd2b9>] drm_ioctl+0x149/0x4f0 [drm]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7f9b515>] ? intel_runtime_pm_put+0x55/0xd0 [i915]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7dec2f0>] ? drm_mode_cursor_ioctl+0x70/0x70 [drm]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<c058b9cf>] ? do_wp_page+0x49f/0x750
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<c06c3608>] ? avc_has_perm+0x48/0xd0
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<f7ddd170>] ? drm_getmap+0xc0/0xc0 [drm]
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<c05d79cc>] do_vfs_ioctl+0x8c/0x730
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<c06c905d>] ? selinux_file_ioctl+0xfd/0x1c0
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<c06bff9c>] ? security_file_ioctl+0x3c/0x60
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<c05d80d8>] SyS_ioctl+0x68/0x80
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<c0401bdd>] do_fast_syscall_32+0x8d/0x150
May 12 01:42:55 arcusvii.nonus-porta.net kernel:  [<c0af66db>] sysenter_past_esp+0x40/0x61
May 12 01:42:55 arcusvii.nonus-porta.net kernel: Code: 70 8d 82 00 00 00 40 c1 e8 0c 8d 0c 80 a1 04 31 ff c0 8d 04 c8 8b 08 80 e5 40 74 7d 90 8d 74 26 00 ba 1c 95 e0 f7 e8 4e 48 7a c8 <0f> 0b 8d 74 26 00 8d 55 ec 8d 45 e4 e8 fd 64 62 c8 84 c0 0f 84
May 12 01:42:55 arcusvii.nonus-porta.net kernel: EIP: [<f7de2c42>] drm_pci_alloc+0xc2/0x1b0 [drm] SS:ESP 0068:e9b1bb9c
May 12 01:42:55 arcusvii.nonus-porta.net kernel: ---[ end trace 0b0f989d78c3a176 ]---

Trace for 4.5.4 (basically the same):

May 12 01:16:38 arcusvii.nonus-porta.net kernel: ------------[ cut here ]------------
May 12 01:16:38 arcusvii.nonus-porta.net kernel: kernel BUG at include/linux/page-flags.h:272!
May 12 01:16:38 arcusvii.nonus-porta.net kernel: invalid opcode: 0000 [#1] SMP 
May 12 01:16:38 arcusvii.nonus-porta.net kernel: Modules linked in: ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_filter ebtable_nat ebtable_broute bridge stp llc ebtables ip6table_raw ip6table_security ip6table_mangle ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_filter ip6_tables iptable_raw iptable_security iptable_mangle iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack bnep arc4 rtl818x_pci mac80211 snd_hda_codec_realtek snd_hda_codec_generic btusb uvcvideo snd_hda_intel iTCO_wdt btrtl msi_wmi snd_hda_codec videobuf2_vmalloc gpio_ich iTCO_vendor_support btbcm sparse_keymap videobuf2_memops btintel videobuf2_v4l2 bluetooth snd_hda_core videobuf2_core cfg80211 coretemp snd_hwdep videodev snd_seq snd_seq_device media snd_pcm joydev lpc_ich eeprom_93cx6
May 12 01:16:38 arcusvii.nonus-porta.net kernel:  rfkill snd_timer wmi acpi_cpufreq snd tpm_tis soundcore tpm nfsd auth_rpcgss nfs_acl lockd grace sunrpc dm_crypt i915 ata_generic i2c_algo_bit drm_kms_helper serio_raw syscopyarea pata_acpi sysfillrect r8169 sysimgblt fb_sys_fops drm mii fjes video ums_realtek uas usb_storage
May 12 01:16:38 arcusvii.nonus-porta.net kernel: CPU: 1 PID: 1341 Comm: gnome-shell Not tainted 4.5.4-200.fc23.i686 #1
May 12 01:16:38 arcusvii.nonus-porta.net kernel: Hardware name: LG Electronics X110-L.A7B1A9/X110, BIOS EN021IL1.10I 11/04/2008
May 12 01:16:38 arcusvii.nonus-porta.net kernel: task: f45d2100 ti: f233c000 task.ti: f233c000
May 12 01:16:39 arcusvii.nonus-porta.net kernel: EIP: 0060:[<f7de2c42>] EFLAGS: 00210282 CPU: 1
May 12 01:16:39 arcusvii.nonus-porta.net kernel: EIP is at drm_pci_alloc+0xc2/0x1b0 [drm]
May 12 01:16:39 arcusvii.nonus-porta.net kernel: EAX: 00000000 EBX: 00040000 ECX: 0000003c EDX: 00000007
May 12 01:16:39 arcusvii.nonus-porta.net kernel: ESI: f2354460 EDI: c04092b0 EBP: f233dbc0 ESP: f233db9c
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
May 12 01:16:39 arcusvii.nonus-porta.net kernel: CR0: 80050033 CR2: b2813000 CR3: 345b0000 CR4: 000006d0
May 12 01:16:39 arcusvii.nonus-porta.net kernel: Stack:
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  024040c0 00000000 f5012864 f8045688 024040c0 63cb2d39 f26d7ff4 f26d8000
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  00000000 f233dbd8 f7fbbb1e 00000100 f6808800 f2347b40 f2347c00 f233dc0c
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  f800216b f490f000 f6ad1000 00200002 f4959600 00000000 f266d400 00000000
May 12 01:16:39 arcusvii.nonus-porta.net kernel: Call Trace:
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7fbbb1e>] i915_gem_object_attach_phys+0xde/0x170 [i915]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f800216b>] intel_prepare_plane_fb+0x19b/0x2d0 [i915]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7dad3a5>] drm_atomic_helper_prepare_planes+0x45/0xb0 [drm_kms_helper]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7ff960c>] intel_atomic_commit+0x7c/0x1770 [i915]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7ffbc9e>] ? intel_atomic_check+0x3de/0x1110 [i915]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<c05b20d5>] ? __kmalloc_track_caller+0x195/0x240
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7ffb8c0>] ? intel_link_compute_m_n+0x50/0x50 [i915]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7df7ccf>] ? drm_atomic_check_only+0x19f/0x690 [drm]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7df74b2>] ? drm_atomic_get_crtc_state+0x52/0xb0 [drm]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<c057a83a>] ? kmemdup+0x2a/0x40
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7df81f2>] drm_atomic_commit+0x32/0x60 [drm]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7daddac>] drm_atomic_helper_update_plane+0xbc/0x100 [drm_kms_helper]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7de7d89>] __setplane_internal+0x1e9/0x230 [drm]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7de7f4e>] drm_mode_cursor_common+0x17e/0x3a0 [drm]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7dec2f0>] ? drm_mode_cursor_ioctl+0x70/0x70 [drm]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7dec2fd>] drm_mode_cursor2_ioctl+0xd/0x10 [drm]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7ddd2b9>] drm_ioctl+0x149/0x4f0 [drm]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7f9b5d5>] ? intel_runtime_pm_put+0x55/0xd0 [i915]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7dec2f0>] ? drm_mode_cursor_ioctl+0x70/0x70 [drm]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<c06c36b8>] ? avc_has_perm+0x48/0xd0
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<f7ddd170>] ? drm_getmap+0xc0/0xc0 [drm]
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<c05d7a5c>] do_vfs_ioctl+0x8c/0x730
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<c06c910d>] ? selinux_file_ioctl+0xfd/0x1c0
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<c06c004c>] ? security_file_ioctl+0x3c/0x60
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<c05d8168>] SyS_ioctl+0x68/0x80
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<c0401bdd>] do_fast_syscall_32+0x8d/0x150
May 12 01:16:39 arcusvii.nonus-porta.net kernel:  [<c0af679b>] sysenter_past_esp+0x40/0x61
May 12 01:16:39 arcusvii.nonus-porta.net kernel: Code: 70 8d 82 00 00 00 40 c1 e8 0c 8d 0c 80 a1 04 31 ff c0 8d 04 c8 8b 08 80 e5 40 74 7d 90 8d 74 26 00 ba 1c 95 e0 f7 e8 4e 48 7a c8 <0f> 0b 8d 74 26 00 8d 55 ec 8d 45 e4 e8 fd 64 62 c8 84 c0 0f 84
May 12 01:16:39 arcusvii.nonus-porta.net kernel: EIP: [<f7de2c42>] drm_pci_alloc+0xc2/0x1b0 [drm] SS:ESP 0068:f233db9c
May 12 01:16:39 arcusvii.nonus-porta.net kernel: ---[ end trace 8efdd04c4db52dc4 ]---

I've looked through other bug reports for 4.5 kernels and didn't spot anything that seemed directly related (though of course, I could've missed something).

Booting gets much farther than either https://bugzilla.redhat.com/show_bug.cgi?id=1302071 or https://bugzilla.redhat.com/show_bug.cgi?id=1301374 and so this seems unrelated.

Comment 1 David H. Gutteridge 2016-05-12 10:41:12 UTC
This is related -- actually, a duplicate, unless there's value in tracking different Fedora releases separately -- to https://bugzilla.redhat.com/show_bug.cgi?id=1303860, which I somehow didn't find before in Bugzilla even when doing a search for "i915"...

Comment 2 Andre Robatino 2016-05-13 13:57:22 UTC
The comments in bug 1303860 indicate that they're using x86_64, so your bug is either not a dupe or not 32-bit specific.

Comment 3 David H. Gutteridge 2016-05-19 19:46:43 UTC
This issue has been resolved by kernel-4.5.5-200.fc23 now available on Koji, presumably because CONFIG_DEBUG_VM_PGFLAGS was disabled.

Comment 4 David H. Gutteridge 2016-05-26 05:21:27 UTC
Also fixed by kernel-4.5.5-201.fc23 now on QA. Closing this bug.


Note You need to log in before you can comment on or make changes to this bug.