Bug 1335410 - Failed to run virt-who-password command in rhev-hypervisor7-ng
Summary: Failed to run virt-who-password command in rhev-hypervisor7-ng
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor-ng
Version: 2.1.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-4.0.0-beta
: ---
Assignee: Douglas Schilling Landgraf
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-12 08:23 UTC by Eko
Modified: 2016-08-23 21:07 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 21:07:36 UTC
oVirt Team: Node


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1702 normal SHIPPED_LIVE redhat-virtualization-host bug fix and enhancement update for RHV 4.0 2016-08-24 00:35:27 UTC

Description Eko 2016-05-12 08:23:23 UTC
Description of problem:
execute virt-who-password command to create an encrypted_password, it will show error msg: 
" Keyfile /var/lib/virt-who/key doesn't exist and can't be created, rerun as root"

Version-Release number of selected component (if applicable):
- rhev-hypervisor7-ng-3.6-20160506.0
- virt-who-0.14-9.el7.noarch
- subscription-manager-1.15.9-15.el7.x86_64
- python-rhsm-1.15.4-5.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. deploy rhev-hypervisor7-ng-3.6-20160506.0

2. login rhev-h by root account

3. run virt-who-password and input "admin" 
# virt-who-password 
Password: 
Keyfile /var/lib/virt-who/key doesn't exist and can't be created, rerun as root

Actual results:
create encrypted_password failed

Expected results:
the encrypted_password value should be created normally

Additional info:

Comment 2 Radek Novacek 2016-05-18 08:52:31 UTC
This is caused by the fact that the filesystem is readonly in RHEV-H.

Can be the file /var/lib/virt-who/key made writable? Or rather whole directory /var/lib/virt-who/? virt-who uses this directory for its internal files which are required for its correct operation. Thanks.

Comment 3 Fabian Deutsch 2016-05-18 10:36:23 UTC
This bug appeared on RHEV-H NG which has a writable filesystem on /var.

Thus it is not a read-only problem.

Eko, do you have a traceback or more detailed logs?

Comment 4 Eko 2016-05-19 09:05:07 UTC
Fabian, I checked it again with rhev-hypervisor7-ng-3.6-20160518.0.x86_64.
can't reproduce this issue any more. verified it.

Comment 7 errata-xmlrpc 2016-08-23 21:07:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1702.html


Note You need to log in before you can comment on or make changes to this bug.