Bug 1335542 - VM start: Invalid Machine Name with specific hostname
Summary: VM start: Invalid Machine Name with specific hostname
Keywords:
Status: CLOSED DUPLICATE of bug 1289363
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: 3.6.5
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact:
URL:
Whiteboard:
Depends On: 1289363
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-12 13:18 UTC by Lionel
Modified: 2016-05-18 10:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-18 10:59:35 UTC
oVirt Team: Virt
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
engine.log (11.30 KB, text/plain)
2016-05-12 13:18 UTC, Lionel
no flags Details

Description Lionel 2016-05-12 13:18:17 UTC
Created attachment 1156676 [details]
engine.log

Description of problem:
Hi,

I have a very strange issue since oVirt was updated to 3.6.5.
When I start VMs with a specific VM name (auto-generated), oVirt returns the following error : 
"Exit message: Invalid machine name"

Version-Release number of selected component (if applicable):
oVirt 3.6.5

How reproducible:
For eg, create a VM with these names fails (from API or from web interface):
kitchen-fermewebovirt-role-webserver-jessie-c_1463043674.809774
kitchen-fermewebovirt-role-webserver-jessie-c_146304367.4809774
kitchen-fermewebovirt-role-webserver-jessie-c_14630436.74809774
kitchen-fermewebovirt-role-webserver-jessie-_1463043674.809774
kitchen-fermewebovirt-role-webserver-jessie-_14630436.74809774

But, these hostnames work:
kitchen-fermewebovirt-role-webserver-jessie-c_1463043.674809774
kitchen-fermewebovirt-role-webserver-jessie-c_1463043674809.774
kitchen-fermewebovirt-role-webserver-jessie-c_146304367480977.4
kitchen-fermewebovirt-role-webserver-jessie-_1463043.674809774
kitchen-fermewebovirt-role-webserver-jessie_1463043674.809774
kitchen-fermewebovirt-role-webserver-c_1463043674.809774


So strange...

Comment 1 Michal Skrivanek 2016-05-13 06:50:03 UTC
related to bug 1291360. Please verify you have 1.2.17-13.el7_2.4 on hosts

There are more bugs which are still in progress, e.g. bug 1289363. I wouldn't use anything longer than 59 chars until things settle down. If you find an issue with 60-64 chars it may be that not-yet-fixed libvirt problem, please feel free to follow up there to see it's the same issue or not

Comment 2 Lionel 2016-05-13 07:46:46 UTC
(In reply to Michal Skrivanek from comment #1)
> related to bug 1291360. Please verify you have 1.2.17-13.el7_2.4 on hosts
> 

Yes, it is the version I have:
libvirt-daemon-kvm-1.2.17-13.el7_2.4.x86_64

Comment 3 Michal Skrivanek 2016-05-13 08:07:40 UTC
then please check if 59 chars long names work and if you have a testing setup you can also try if libvirt 1.3.4 would help(you may need to compile it yourself though, so not simple to try)

Comment 4 Lionel 2016-05-13 14:40:52 UTC
(In reply to Michal Skrivanek from comment #3)
> then please check if 59 chars long names work and if you have a testing
> setup you can also try if libvirt 1.3.4 would help(you may need to compile
> it yourself though, so not simple to try)

Yes, I am not able to reproduce the issue when length <= 59 chars.
I will reduce hostname length during generation into library I use (vagrant-ovirt3).

Thanks for your help.

Comment 5 Tomas Jelinek 2016-05-18 10:59:35 UTC

*** This bug has been marked as a duplicate of bug 1289363 ***


Note You need to log in before you can comment on or make changes to this bug.