Bug 1335567 - Update Warning in IdM Web UI API browser
Summary: Update Warning in IdM Web UI API browser
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-12 14:10 UTC by Petr Vobornik
Modified: 2016-11-04 05:54 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:54:08 UTC


Attachments (Terms of Use)
warning.png (134.50 KB, image/png)
2016-09-06 12:49 UTC, Abhijeet Kasurde
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Petr Vobornik 2016-05-12 14:10:45 UTC
Description of problem:
API browser in RHEL 7.2 is a tech preview. It is indicated by a warning in Web UI. The warning needs to be removed when it will stops being tech preview.

Version-Release number of selected component (if applicable):
All 4.2.x

How reproducible:
always


Steps to Reproduce:
1. open Web UI in tab IPA server/API browser

Actual results:
Tech preview warning is displayed in the page header.

Expected results:
There is no tech preview warning in the page header.

Additional info:

Comment 4 Martin Kosek 2016-08-18 06:56:56 UTC
The warning currently states:

~~~
Please be aware that the API may change and the API browser is an experimental feature.
~~~

I suggest something like following:

~~~
Please be aware that the IdM API Browser and the API itself is a Tech Preview feature and may change.
~~~

CCing Aneta to check the wording.

Comment 5 Aneta Šteflová Petrová 2016-08-18 07:26:15 UTC
I just propose a few minor editorial changes: "Be aware that the IdM API Browser and the API itself are Technology Preview features and might therefore change."

Comment 7 Aneta Šteflová Petrová 2016-08-18 07:46:54 UTC
Also, you can add a link to https://access.redhat.com/support/offerings/techpreview/  which explains that the scope of TPs is limited.

Comment 8 Martin Kosek 2016-08-18 08:23:38 UTC
Thanks Aneta! The updated warning looks good to me.

Comment 10 Abhijeet Kasurde 2016-09-06 12:49 UTC
Created attachment 1198253 [details]
warning.png

Verified using IPA version::
ipa-server-4.4.0-9.el7.x86_64

Marking BZ as verified.

Comment 12 errata-xmlrpc 2016-11-04 05:54:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.