Bug 133557 - session dbus does not quit with X session
Summary: session dbus does not quit with X session
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xinitrc   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks: SessionExit
TreeView+ depends on / blocked
 
Reported: 2004-09-24 19:43 UTC by Bryan W Clark
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version: xinitrc-4.0.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 08:07:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add --exit-with-session (1.26 KB, patch)
2004-09-27 18:33 UTC, Colin Walters
no flags Details | Diff

Description Bryan W Clark 2004-09-24 19:43:47 UTC
After logging in and out several times there are multiple
dbus-daemon-1 processes running.  Each process should destroy when the
session ends.

It seems that --exit-with-session isn't part of the argument list to
dbus-launch and would force this to happen.

Comment 1 Colin Walters 2004-09-24 19:50:24 UTC
I can take care of this unless Mike beats me to it.

Comment 2 Colin Walters 2004-09-27 16:35:48 UTC
After talking with Mike this is pending on getting xinitrc moved to
cvs.dist instead of elvis.

Comment 3 Colin Walters 2004-09-27 18:33:27 UTC
Created attachment 104393 [details]
patch to add --exit-with-session

Comment 4 Colin Walters 2004-09-27 18:34:47 UTC
Reassigning to Mike since he knows best what's going on with the cvs
migration, and can apply this patch.

Comment 5 Ray Strode [halfline] 2004-10-04 21:04:29 UTC
Hey Mike,
Any progress on this?

Comment 6 Mike A. Harris 2004-10-05 08:07:30 UTC
Fixed in xinitrc-4.0.7-1 in rawhide.


Note You need to log in before you can comment on or make changes to this bug.