Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1335576 - Calculation for virt pool needs to account for unlimited master pool
Summary: Calculation for virt pool needs to account for unlimited master pool
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: William Poteat
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-12 14:32 UTC by William Poteat
Modified: 2016-07-22 14:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-22 14:52:25 UTC


Attachments (Terms of Use)

Description William Poteat 2016-05-12 14:32:43 UTC
Description of problem: Master pool quantity is -1 for unlimited for master. If the virt limit is finite [i.e. 4] then the derived pool gets a quantity of -4, which is also unlimited. We need to maintain the guest pool limit per host.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 William Poteat 2016-05-13 17:07:25 UTC
The issue is stated incorrectly in the description.

The unmapped guest pool should be unlimited. A host dependent pool that is created from entitling the host should have the limited quantity specified.

Comment 2 William Poteat 2016-05-23 14:39:09 UTC
master commit 5876dd6d07d28db12341eb1db3785f3a57bd24d6

Comment 3 Barnaby Court 2016-07-22 14:52:25 UTC
Marking as closed per Candlepin procedures as a fix has been merged or it has been determined to not be an issue.


Note You need to log in before you can comment on or make changes to this bug.