Bug 1335663 - All day events from google calendar end up being 2 day events in gnome calendar
Summary: All day events from google calendar end up being 2 day events in gnome calendar
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: 24
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-12 19:35 UTC by srakitnican
Modified: 2016-08-15 19:56 UTC (History)
6 users (show)

Fixed In Version: evolution-data-server-3.20.5 evolution-data-server-3.20.5-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-09 18:18:59 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 766346 0 None None None 2016-08-03 07:17:03 UTC

Description srakitnican 2016-05-12 19:35:10 UTC
Description of problem: All day events from google calendar integration are showing up as correct day in gnome calendar plus one more day, being duplicated into two days.


Version-Release number of selected component (if applicable):
gnome-shell-3.20.2-1.fc24.x86_64

How reproducible: 


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info: https://bugzilla.gnome.org/show_bug.cgi?id=766346

Comment 1 Dale Turner 2016-07-06 01:03:22 UTC
I have been getting this behaviour as well, for some time. I believe it began when I upgraded to F24 during the alpha stage. F23 was fine, as far as I can remember.

Comment 2 Eric Work 2016-07-21 09:27:36 UTC
I wonder if it has anything to do with timezone?  I'm seeing the same behavior except it's duplicated the day before.  For example my brother's birthday is July 31st, but it also shows up in the top calendar under July 30th.  My system is set to America/Los_Angeles.

Comment 3 Florian Müllner 2016-07-21 10:24:30 UTC
Yes, evolution-data-server changed the implementation of the API we are using, and the handling of all-day events is different from the previous one, see https://bugzilla.gnome.org/show_bug.cgi?id=766346.

Comment 4 Milan Crha 2016-08-03 07:17:04 UTC
Thanks for a bug report. This had been addressed upstream [1] and the fix will be available in the evolution-data-server 3.20.5 release. A pre-release testing will be appreciated, I can build a test package for that purpose, if you are interested in the testing.

By the way, there is usually no need to duplicate bugs between bugzillas, the upstream bug is more important, at least from my point of view.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=766346

Comment 5 srakitnican 2016-08-03 09:11:18 UTC
(In reply to Milan Crha from comment #4)
> Thanks for a bug report. This had been addressed upstream [1] and the fix
> will be available in the evolution-data-server 3.20.5 release. A pre-release
> testing will be appreciated, I can build a test package for that purpose, if
> you are interested in the testing.

Yes, please. Package for testing would be appreciated.

> By the way, there is usually no need to duplicate bugs between bugzillas,
> the upstream bug is more important, at least from my point of view.

While upstream can be resolved, bug can still be present in current older version of distribution package. So I made this one for packagers, if they don't intent to update package to a newer version due to instability, can at least backport a fix for this bug to older version?


Thanks

> [1] https://bugzilla.gnome.org/show_bug.cgi?id=766346

Comment 6 Milan Crha 2016-08-03 10:49:57 UTC
Thanks, the test package is currently building at:
http://koji.fedoraproject.org/koji/taskinfo?taskID=15116783
Make sure you'll restart the machine after installing it (see bug #1340203), to have the new bits in action.

The decision is always on respective package maintainer(s). The 3.20.5 is planned for the next Monday, then it'll get to the Fedora. Having a confirmation before Monday would be nice, either positive or negative, thus there will be time for any particular follow up fixes. My local testing didn't show any issue, but it happened to me couple times that local testing didn't always catch all real life cases. Thanks again for your help with this.

Comment 7 srakitnican 2016-08-03 11:42:59 UTC
evolution-data-server-3.20.4-1.2.fc24.x86_64.rpm fixes it for me as well, thank you.

Comment 8 Milan Crha 2016-08-03 11:49:04 UTC
Nice, thanks a lot for a quick testing and confirmation.

Comment 9 Fedora Update System 2016-08-08 14:32:56 UTC
evolution-ews-3.20.5-1.fc24 evolution-3.20.5-1.fc24 evolution-data-server-3.20.5-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c34a709e9b

Comment 10 Fedora Update System 2016-08-09 01:26:12 UTC
evolution-3.20.5-1.fc24, evolution-data-server-3.20.5-1.fc24, evolution-ews-3.20.5-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c34a709e9b

Comment 11 Fedora Update System 2016-08-09 18:18:55 UTC
evolution-3.20.5-1.fc24, evolution-data-server-3.20.5-1.fc24, evolution-ews-3.20.5-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 srakitnican 2016-08-14 12:30:36 UTC
Bug is present in evolution-data-server-3.21.4-1.fc25.x86_64 from "fedora" repository, can this be fixed for F25 as well?

Comment 13 Milan Crha 2016-08-15 13:17:49 UTC
(In reply to srakitnican from comment #12)
> Bug is present in evolution-data-server-3.21.4-1.fc25.x86_64 from "fedora"
> repository, can this be fixed for F25 as well?

There was a 3.21.90 release done today. Wait a bit, until it's built and available for downloading for rawhide and F25.

Comment 14 srakitnican 2016-08-15 19:56:16 UTC
Packages for both Fedora versions works as expected, thank you for a quick response!


Note You need to log in before you can comment on or make changes to this bug.