Bug 1335688 - Packstack installation fails on 'Invalid parameter firewall_driver on Class[Neutron::Plugins::Ml2]'
Summary: Packstack installation fails on 'Invalid parameter firewall_driver on Class[N...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Emilien Macchi
QA Contact: Prasanth Anbalagan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-12 23:05 UTC by Arie Bregman
Modified: 2016-08-11 12:19 UTC (History)
8 users (show)

Fixed In Version: openstack-puppet-modules-8.0.4-1.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 12:19:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1597 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 Release Candidate Advisory 2016-08-11 16:06:52 UTC

Description Arie Bregman 2016-05-12 23:05:31 UTC
Description of problem: Packstack installation fails due to the following error: "Invalid parameter firewall_driver on Class[Neutron::Plugins::Ml2]"

Version-Release number of selected component (if applicable): 9

How reproducible: 100%


Steps to Reproduce:

1. Install RHOSP 9 poodle repo

2. Create the following answer file:

      CONFIG_NEUTRON_OVS_VLAN_RANGES: myphysnet
      CONFIG_PROVISION_TEMPEST: n
      CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS: myphysnet:br-myphysnet
      CONFIG_LBAAS_INSTALL: y
      CONFIG_NEUTRON_L2_AGENT: openvswitch
      CONFIG_HEAT_INSTALL: n
      CONFIG_NEUTRON_FWAAS: y
      CONFIG_NEUTRON_L2_PLUGIN: ml2
      CONFIG_HEAT_CFN_INSTALL: n
      CONFIG_NEUTRON_USE_NAMESPACES: y
      CONFIG_NOVA_NETWORK_DEFAULTFLOATINGPOOL: public
      CONFIG_NEUTRON_OVS_TUNNEL_RANGES: 1:1000
      CONFIG_NAGIOS_INSTALL: n
      CONFIG_SWIFT_INSTALL: n
      CONFIG_NEUTRON_ML2_VNI_RANGES: 10:50000
      CONFIG_CEILOMETER_INSTALL: n
      CONFIG_AMQP_BACKEND: rabbitmq
      CONFIG_NEUTRON_ML2_TUNNEL_ID_RANGES: 1:1000
      CONFIG_NEUTRON_ML2_TENANT_NETWORK_TYPES: vxlan
      CONFIG_NEUTRON_L3_EXT_BRIDGE: provider
      CONFIG_NEUTRON_INSTALL: y
      CONFIG_PROVISION_DEMO: n
      CONFIG_NEUTRON_OVS_BRIDGE_IFACES: br-myphysnet:eth2
      CONFIG_NEUTRON_ML2_VLAN_RANGES: myphysnet
      CONFIG_HORIZON_INSTALL: n
      CONFIG_NEUTRON_METERING_AGENT_INSTALL: y
      CONFIG_NEUTRON_ML2_TYPE_DRIVERS: local,flat,vxlan,vlan
      CONFIG_NEUTRON_OVS_TENANT_NETWORK_TYPE: vxlan

3. Start all-in-one or multi-node installation

Actual results:

192.168.1.13_neutron.pp:                          [ ERROR ]
21:33:11 Applying Puppet manifests                         [ ERROR ]
21:33:11 
21:33:11 ERROR : Error appeared during Puppet run: 192.168.1.13_neutron.pp
21:33:11 Error: Invalid parameter firewall_driver on Class[Neutron::Plugins::Ml2] at /var/tmp/packstack/b74529d1afaf4c779ada218a99ec26d6/manifests/192.168.1.13_neutron.pp:149 on node q79dc-rhos-ci-346-rh-pod-pksk-controller.openstacklocal
21:33:11 You will find full trace in log /var/tmp/packstack/20160512-172707-GaBvv9/manifests/192.168.1.13_neutron.pp.log
21:33:11 

Expected results:

**** Installation completed successfully ******

Comment 3 Anshul Behl 2016-05-18 10:12:49 UTC
I am also encountering the same error while packstack installation

ERROR : Error appeared during Puppet run: 172.16.150.67_neutron.pp
Error: Invalid parameter firewall_driver on Class[Neutron::Plugins::Ml2] at /var/tmp/packstack/080f2cd12e1d485ca04568aa00382c57/manifests/172.16.150.67_neutron.pp:131 on node anshul-packstack2.os1.phx2.redhat.com
You will find full trace in log /var/tmp/packstack/20160518-030958-O4Bx9k/manifests/172.16.150.67_neutron.pp.log

Comment 4 Alfredo Moralejo 2016-05-19 15:42:54 UTC
What version of openstack-puppet-modules are you using?

Comment 5 Jon Schlueter 2016-05-19 15:54:26 UTC
one job was running against openstack-puppet-modules-8.0.0-1.el7ost

Comment 6 Alfredo Moralejo 2016-05-19 17:17:03 UTC
this was fixed in version 8.0.3. Could you test with latest version openstack-puppet-modules-8.0.4-1.el7.noarch. I've been able to properly run a packstack aio with this version of opm.

Comment 8 Prasanth Anbalagan 2016-06-10 18:22:14 UTC
Verified as follows,

***********
VERSION
***********

[root@serverA ~]# yum list installed | grep puppet-modules
openstack-puppet-modules.noarch      1:8.0.4-1.el7ost        @rhelosp-9.0-puddle

*******
LOGS
******

[root@serverA ~]# packstack --answer-file=answer.txt
Welcome to the Packstack setup utility

The installation log file is available at: /var/tmp/packstack/20160610-201744-MpTQqg/openstack-setup.log

Installing:
Clean Up                                             [ DONE ]
Discovering ip protocol version                      [ DONE ]
root@X.X.X.X's password: 
root@X.X.X.X's password: 
root@X.X.X.X's password: 
Setting up ssh keys                                  [ DONE ]
Preparing servers                                    [ DONE ]
Pre installing Puppet and discovering hosts' details [ DONE ]
Adding pre install manifest entries                  [ DONE ]
Setting up CACERT                                    [ DONE ]
Adding AMQP manifest entries                         [ DONE ]
Adding MariaDB manifest entries                      [ DONE ]
Adding Apache manifest entries                       [ DONE ]
Fixing Keystone LDAP config parameters to be undef if empty[ DONE ]
Adding Keystone manifest entries                     [ DONE ]
Adding Glance Keystone manifest entries              [ DONE ]
Adding Glance manifest entries                       [ DONE ]
Adding Cinder Keystone manifest entries              [ DONE ]
Checking if the Cinder server has a cinder-volumes vg[ DONE ]
Adding Cinder manifest entries                       [ DONE ]
Adding Nova API manifest entries                     [ DONE ]
Adding Nova Keystone manifest entries                [ DONE ]
Adding Nova Cert manifest entries                    [ DONE ]
Adding Nova Conductor manifest entries               [ DONE ]
Creating ssh keys for Nova migration                 [ DONE ]
Gathering ssh host keys for Nova migration           [ DONE ]
Adding Nova Compute manifest entries                 [ DONE ]
Adding Nova Scheduler manifest entries               [ DONE ]
Adding Nova VNC Proxy manifest entries               [ DONE ]
Adding OpenStack Network-related Nova manifest entries[ DONE ]
Adding Nova Common manifest entries                  [ DONE ]
Adding Neutron VPNaaS Agent manifest entries         [ DONE ]
Adding Neutron FWaaS Agent manifest entries          [ DONE ]
Adding Neutron LBaaS Agent manifest entries          [ DONE ]
Adding Neutron API manifest entries                  [ DONE ]
Adding Neutron Keystone manifest entries             [ DONE ]
Adding Neutron L3 manifest entries                   [ DONE ]
Adding Neutron L2 Agent manifest entries             [ DONE ]
Adding Neutron DHCP Agent manifest entries           [ DONE ]
Adding Neutron Metering Agent manifest entries       [ DONE ]
Adding Neutron Metadata Agent manifest entries       [ DONE ]
Adding Neutron SR-IOV Switch Agent manifest entries  [ DONE ]
Checking if NetworkManager is enabled and running    [ DONE ]
Adding OpenStack Client manifest entries             [ DONE ]
Adding Horizon manifest entries                      [ DONE ]
Adding Swift Keystone manifest entries               [ DONE ]
Adding Swift builder manifest entries                [ DONE ]
Adding Swift proxy manifest entries                  [ DONE ]
Adding Swift storage manifest entries                [ DONE ]
Adding Swift common manifest entries                 [ DONE ]
Adding Provisioning manifest entries                 [ DONE ]
Adding Provisioning Glance manifest entries          [ DONE ]
Adding Provisioning Demo bridge manifest entries     [ DONE ]
Adding Gnocchi manifest entries                      [ DONE ]
Adding Gnocchi Keystone manifest entries             [ DONE ]
Adding MongoDB manifest entries                      [ DONE ]
Adding Redis manifest entries                        [ DONE ]
Adding Ceilometer manifest entries                   [ DONE ]
Adding Ceilometer Keystone manifest entries          [ DONE ]
Adding Aodh manifest entries                         [ DONE ]
Adding Aodh Keystone manifest entries                [ DONE ]
Copying Puppet modules and manifests                 [ DONE ]
Applying X.X.X.X_prescript.pp
Applying X.X.X.X_prescript.pp
Applying X.X.X.X_prescript.pp
X.X.X.X_prescript.pp:                          [ DONE ]         
X.X.X.X_prescript.pp:                              [ DONE ]         
X.X.X.X_prescript.pp:                           [ DONE ]         
Applying X.X.X.X_amqp.pp
Applying X.X.X.X_mariadb.pp
X.X.X.X_amqp.pp:                                   [ DONE ]   
X.X.X.X_mariadb.pp:                                [ DONE ]   
Applying X.X.X.X_apache.pp
X.X.X.X_apache.pp:                                 [ DONE ]  
Applying X.X.X.X_keystone.pp
Applying X.X.X.X_glance.pp
Applying X.X.X.X_cinder.pp
X.X.X.X_keystone.pp:                               [ DONE ]    
X.X.X.X_cinder.pp:                                 [ DONE ]    
X.X.X.X_glance.pp:                                 [ DONE ]    
Applying X.X.X.X_api_nova.pp
X.X.X.X_api_nova.pp:                               [ DONE ]    
Applying X.X.X.X_nova.pp
Applying X.X.X.X_nova.pp
Applying X.X.X.X_nova.pp
X.X.X.X_nova.pp:                                   [ DONE ]    
X.X.X.X_nova.pp:                               [ DONE ]    
X.X.X.X_nova.pp:                                [ DONE ]    
Applying X.X.X.X_neutron.pp
Applying X.X.X.X_neutron.pp
Applying X.X.X.X_neutron.pp
X.X.X.X_neutron.pp:                            [ DONE ]       
X.X.X.X_neutron.pp:                                [ DONE ]       
X.X.X.X_neutron.pp:                             [ DONE ]       
Applying X.X.X.X_osclient.pp
Applying X.X.X.X_horizon.pp
X.X.X.X_osclient.pp:                               [ DONE ]    
X.X.X.X_horizon.pp:                                [ DONE ]    
Applying X.X.X.X_ring_swift.pp
X.X.X.X_ring_swift.pp:                             [ DONE ]      
Applying X.X.X.X_swift.pp
X.X.X.X_swift.pp:                                  [ DONE ] 
Applying X.X.X.X_provision.pp
Applying X.X.X.X_provision_glance
X.X.X.X_provision.pp:                              [ DONE ]         
X.X.X.X_provision_glance:                          [ DONE ]         
Applying X.X.X.X_provision_bridge.pp
X.X.X.X_provision_bridge.pp:                       [ DONE ]            
Applying X.X.X.X_gnocchi.pp
X.X.X.X_gnocchi.pp:                                [ DONE ]   
Applying X.X.X.X_mongodb.pp
Applying X.X.X.X_redis.pp
X.X.X.X_mongodb.pp:                                [ DONE ]   
X.X.X.X_redis.pp:                                  [ DONE ]   
Applying X.X.X.X_ceilometer.pp
X.X.X.X_ceilometer.pp:                             [ DONE ]      
Applying X.X.X.X_aodh.pp
X.X.X.X_aodh.pp:                                   [ DONE ]
Applying Puppet manifests                            [ DONE ]
Finalizing                                           [ DONE ]

 **** Installation completed successfully ******

Additional information:
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
 * Warning: NetworkManager is active on X.X.X.X, X.X.X.X, X.X.X.X. OpenStack networking currently does not work on systems that have the Network Manager service enabled.
 * File /root/keystonerc_admin has been created on OpenStack client host X.X.X.X. To use the command line tools you need to source the file.
 * To access the OpenStack Dashboard browse to http://X.X.X.X/dashboard .
Please, find your login credentials stored in the keystonerc_admin in your home directory.
 * The installation log file is available at: /var/tmp/packstack/20160610-201744-MpTQqg/openstack-setup.log
 * The generated manifests are available at: /var/tmp/packstack/20160610-201744-MpTQqg/manifests

Comment 10 errata-xmlrpc 2016-08-11 12:19:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1597.html


Note You need to log in before you can comment on or make changes to this bug.