Bug 1335705 - 'QEMU 2.5.94 monitor' is used for qemu-kvm-rhev-2.6.0-1.el7.x86_64
Summary: 'QEMU 2.5.94 monitor' is used for qemu-kvm-rhev-2.6.0-1.el7.x86_64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Miroslav Rezanina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-13 02:57 UTC by Gu Nini
Modified: 2016-11-07 21:07 UTC (History)
11 users (show)

Fixed In Version: qemu-kvm-rhev-2.6.0-4.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 21:07:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Gu Nini 2016-05-13 02:57:33 UTC
Description of problem:

In a host with packages qemu-kvm-rhev-2.6.0-1.el7.x86_64/3.10.0-396.el7.x86_64, after start a guest with qemu-kvm command and connect to its qmp/hmp monitor, it displays as 'QEMU 2.5.94 monitor'.

Version-Release number of selected component (if applicable):
Host kernel: 3.10.0-396.el7.x86_64
Qemu-kvm-rhev: qemu-kvm-rhev-2.6.0-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Start a guest with qemu-kvm command and with qmp/hmp monitors:

# /usr/libexec/qemu-kvm \
>     -name 'avocado-vt-vm1'  \
>     -chardev socket,id=qmpmonitor1,path=/var/tmp/qmpmonitor1,server,nowait \
>     -mon chardev=qmpmonitor1,mode=control  \
>     -vnc :0  \
>     -enable-kvm \
>     -monitor stdio
QEMU 2.5.94 monitor - type 'help' for more information
(qemu) 

2. Try to connect to its qmp monitor:

# nc -U /var/tmp/qmpmonitor1
{"QMP": {"version": {"qemu": {"micro": 94, "minor": 5, "major": 2}, "package": " (qemu-kvm-rhev-2.6.0-1.el7)"}, "capabilities": []}}


Actual results:
In steps 1 and 2, QEMU 2.5.94 monitor was used.

Expected results:
QEMU 2.6.0 monitor should be used

Additional info:

Comment 2 Jeff Nelson 2016-05-21 01:19:57 UTC
I can't reproduce this, not even when I try with qemu-kvm-rhev-2.6.0-1. You might have discovered this with an early preview of qemu-kvm-rhev-2.6.0-1.

Can you please retest with the current release, qemu-kvm-rhev-2.6.0-2? I would give a pointer to the build, but Brew is offline, so I can't. Let me know if you need assistance locating it.

Comment 5 Miroslav Rezanina 2016-05-25 08:46:27 UTC
Fix included in qemu-kvm-rhev-2.6.0-4.el7

Comment 7 Gu Nini 2016-05-26 10:18:00 UTC
Verify the bug. Now it works well on qemu-kvm-rhev-2.6.0-4.el7.

Comment 9 errata-xmlrpc 2016-11-07 21:07:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.