Bug 133573 - Cross compiling - configure failes on RPM 4.3.2-2
Summary: Cross compiling - configure failes on RPM 4.3.2-2
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-24 21:04 UTC by Mark Hatle
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-29 16:19:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the MYPATH for crosscompilation. (510 bytes, patch)
2005-01-29 15:51 UTC, Chris Larson
no flags Details | Diff

Description Mark Hatle 2004-09-24 21:04:14 UTC
When cross compiling RPM 4.3.2-2, some mysterious failures occur.

Errors similar to below occur:

checking libelf.h usability... no
checking libelf.h presence... yes
configure: WARNING: libelf.h: present but cannot be compiled
configure: WARNING: libelf.h:     check for missing prerequisite headers?
configure: WARNING: libelf.h: see the Autoconf documentation
configure: WARNING: libelf.h:     section "Present But Cannot Be Compiled"
configure: WARNING: libelf.h: proceeding with the preprocessor's result
configure: WARNING: libelf.h: in the future, the compiler will take
precedence
configure: WARNING:     ## ---------------------------------- ##
configure: WARNING:     ## Report this to rpm-list@redhat.com ##
configure: WARNING:     ## ---------------------------------- ##

Comment 1 Mark Hatle 2004-09-24 21:05:57 UTC
The problem was tracked down to a configure.ac statement:

dnl
dnl use defaults if cross-compiling, otherwise use the default path.
dnl
if test "$cross_compiling" = "yes"; then
    MYPATH=""
else
#   
MYPATH="/bin:/usr/bin:/usr/local/bin:$PATH:/sbin:/usr/sbin:/usr/local/sbin:/opt/gnu/bin"
    MYPATH=$PATH
fi

If you change 'MYPATH=""' to 'MYPATH=":"' the problem goes away, and
the desired behavior (according to the comment) occurs.

Comment 2 Chris Larson 2005-01-29 15:51:17 UTC
Created attachment 110382 [details]
Patch to fix the MYPATH for crosscompilation.

Comment 3 Jeff Johnson 2005-01-29 16:19:46 UTC
Checked in on HEAD and rpm-4_{4,3,2} branches. Thanks for the patch.

Should be in rpm-4.4.1-0.13 and later when built.


Note You need to log in before you can comment on or make changes to this bug.