Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1335732 - Upgrade [sat618 -> 6.2 snap11.0] failed with error: You are trying to replace existing installation with different scenario
Summary: Upgrade [sat618 -> 6.2 snap11.0] failed with error: You are trying to replace...
Keywords:
Status: CLOSED DUPLICATE of bug 1335668
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Upgrades
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 1335807
TreeView+ depends on / blocked
 
Reported: 2016-05-13 06:43 UTC by Sachin Ghai
Modified: 2019-04-01 20:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-16 12:38:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sachin Ghai 2016-05-13 06:43:38 UTC
Description of problem:
I initiated upgrade from  sat618 -> 6.2 snap11.0 using cmd:
satellite-installer --scenario satellite --upgrade

and it failed with error:

[qe-sat6-upgrade-rhel7.satqe.lab.eng.rdu2.redhat.com] out: [ERROR 2016-05-13 02:26:07 verbose] You are trying to replace existing installation with different scenario. This may lead to unpredictable states. Use --force to override. You can use --compare-scenarios to see the differences

On checking installer help, I got another error. At first place with --help, user shouldn't get any error, it could be a generic message.

~]# satellite-installer --help
ERROR: Selected scenario is DISABLED, can not continue. Use --list-scenarios to list available options. You can also --enable-scenario SCENARIO to make the selected scenario available.


[root@qe-sat6-upgrade-rhel7 ~]# satellite-installer --list-scenarios
Available scenarios
  Capsule (use: --scenario capsule)
        Install a stand-alone Capsule.
  Satellite (use: --scenario satellite)
        Install Satelite server


I enabled the scenario explicitly and still getting:
-----------------------------------------------------

 ~]# satellite-installer --enable-scenario satellite
Scenario satellite was enabled

[root@qe-sat6-upgrade-rhel7 ~]# satellite-installer --help
ERROR: Selected scenario is DISABLED, can not continue. Use --list-scenarios to list available options. You can also --enable-scenario SCENARIO to make the selected scenario available.

Again initiated upgrade:
=========================

# satellite-installer --scenario satellite --upgrade
[ INFO 2016-05-13 02:35:48 verbose] Executing hooks in group pre_migrations
[ INFO 2016-05-13 02:35:48 verbose] All hooks in group pre_migrations finished
[ERROR 2016-05-13 02:35:48 verbose] You are trying to replace existing installation with different scenario. This may lead to unpredictable states. Use --force to override. You can use --compare-scenarios to see the differences
[ INFO 2016-05-13 02:35:48 verbose] Log was be written to /var/log/foreman-installer/satellite.log
[ INFO 2016-05-13 02:35:48 verbose] Logs flushed


As per satellite log:
=======================
[DEBUG 2016-05-13 02:35:48 main] Exit with status code: 27 (signal was scenario_error)
[DEBUG 2016-05-13 02:35:48 main] Cleaning /tmp/default_values.yaml
[DEBUG 2016-05-13 02:35:48 main] Exit with status code: 27 (signal was 27)
[DEBUG 2016-05-13 02:35:48 main] Cleaning /tmp/default_values.yaml



Version-Release number of selected component (if applicable):
upgrade sat6.1.8 to sat6.2 snap11.0

How reproducible:


Steps to Reproduce:
1. perform upgrade from Sat6.1.8 to sat6.2 snap11.0
2.
3.

Actual results:
couldn't proceed with upgrade and error out:

You are trying to replace existing installation with different scenario. This may lead to unpredictable states. Use --force to override. You can use --compare-scenarios to see the differences
[ INFO 2016-05-13 02:35:48 verbose] Log was be written to /var/log/foreman-installer/satellite.log

Expected results:
user should be able to perform upgrade with satellite-installer and it should be friendly enough to provide help options.

Additional info:

Comment 1 Sachin Ghai 2016-05-13 06:48:24 UTC
If I don't use --scenario option then again same result:

#  satellite-installer --upgrade
ERROR: Selected scenario is DISABLED, can not continue. Use --list-scenarios to list available options. You can also --enable-scenario SCENARIO to make the selected scenario available.

Comment 2 Sachin Ghai 2016-05-13 06:56:17 UTC
Please make a note, I can proceed with upgrade with --force option:

# satellite-installer --scenario satellite --upgrade --force

But upgrade *shouldn't* be run only with --force option.

Couple of things needs to be fixed:


1) user should be able to perform upgrade with any of these cmds:

a) satellite-installer --scenario satellite --upgrade
b) satellite-installer --upgrade

2) User shouldn't get error:
You are trying to replace existing installation with different scenario.

we may raise this as generic message.

3) satellite-installer --help
ERROR: Selected scenario is DISABLED, can not continue. Use --list-scenarios to list available options. You can also --enable-scenario SCENARIO to make the selected scenario available.


user should be able to see all installer options with "--help"


Since all issues are related, so I'm combining all issues in one bz. However, If you would like separate bz's, just ping here and I'll be happy to do that.

Comment 3 Sachin Ghai 2016-05-13 06:57:48 UTC
Note: Since I was able to proceed with upgrade using --force option but it failed at migration step. I'll file another issue for that.

Comment 5 Brad Buckingham 2016-05-16 12:38:11 UTC

*** This bug has been marked as a duplicate of bug 1335668 ***


Note You need to log in before you can comment on or make changes to this bug.