Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1335776 - rpc: change client insecure port ceiling from 65535 to 49151
Summary: rpc: change client insecure port ceiling from 65535 to 49151
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1335813 1335815
TreeView+ depends on / blocked
 
Reported: 2016-05-13 08:14 UTC by Prasanna Kumar Kalever
Modified: 2017-03-27 18:11 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1335813 1337127 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:11:09 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Prasanna Kumar Kalever 2016-05-13 08:14:56 UTC
Description of problem:
current port allocation to various processes (clumsy):
    
 1023 - 1       -> client ports range if bind secure is turned on
49151 - 1024    -> fall back to this, if in above case ports exhaust
65535 - 1024    -> client port range if bind insecure is on
49152 - 65535   -> brick port range
    
now, we should have segregated port ranges 0 - 65535 to below 3 ranges
    
 1023 - 1       -> client ports range if bind secure is turned on
49151 - 1024    -> client port range if bind insecure is on
                   (fall back to this, if in above case ports exhaust)
49152 - 65535   -> brick port range
    
for a cleaner way of segregation this is necessary, and since  bind insecure
is on by default, there could be a chance of port clashes between brick and clients

Version-Release number of selected component (if applicable):
mainline

Comment 1 Vijay Bellur 2016-05-13 08:20:20 UTC
REVIEW: http://review.gluster.org/14326 (rpc: change client insecure port ceiling from 65535 to 49151) posted (#1) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 2 Vijay Bellur 2016-05-18 10:26:04 UTC
COMMIT: http://review.gluster.org/14326 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 58615482ed87ff4b8253081c6ea26471fcf09070
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Fri May 13 13:17:16 2016 +0530

    rpc: change client insecure port ceiling from 65535 to 49151
    
    current port allocation to various processes (clumsy):
    
     1023 - 1       -> client ports range if bind secure is turned on
    49151 - 1024    -> fall back to this, if in above case ports exhaust
    65535 - 1024    -> client port range if bind insecure is on
    49152 - 65535   -> brick port range
    
    now, we have segregated port ranges 0 - 65535 to below 3 ranges
    
     1023 - 1       -> client ports range if bind secure is turned on
    49151 - 1024    -> client port range if bind insecure is on
                       (fall back to this, if in above case ports exhaust)
    49152 - 65535   -> brick port range
    
    so now we have a clean segregation of port mapping
    
    Change-Id: Ie3b4e7703e0bbeabbe0adbdd6c60d9ef78ef7c65
    BUG: 1335776
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Reviewed-on: http://review.gluster.org/14326
    Tested-by: Prasanna Kumar Kalever <pkalever@redhat.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 3 Shyamsundar 2017-03-27 18:11:09 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.