Bug 133582 - yum crashes when updating certain packages
yum crashes when updating certain packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-24 17:22 EDT by Chris Lee
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-13 13:58:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of yum crashing on update (1.08 KB, text/plain)
2004-09-24 17:25 EDT, Chris Lee
no flags Details

  None (edit)
Description Chris Lee 2004-09-24 17:22:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
When I run 'sudo yum update', yum will show me a list of all of the
available updates to my existing packages and ask me 'Is this ok?' to
which I reply "yes".

However, with certain packages, yum will crash after I reply 'yes' but
before it even makes it to the test transaction. The following is an
excerpt from a conversation I had with skvidal about this bug:

13:44 <clee> I'm getting an OSError closing a file descriptor but only
when I try to 'yum update' certain packages
13:44 <clee> was wondering if you'd seen that
13:45 <skvidal> it's a gpgcheck issue
13:45 <skvidal> I'm closing a file descriptor I already closed
13:45 <clee> aha.

Will attach yum's output to this bugreport.

Version-Release number of selected component (if applicable):
yum_2.1.3-1_noarch

How reproducible:
Always

Steps to Reproduce:
1. Run 'sudo yum update'
2. Answer 'y' to "Is this ok?"
3. Watch yum crash and burn

Actual Results:  yum crashed and gave me a traceback.

Expected Results:  yum should have upgraded the packages without crashing.

Additional info:
Comment 1 Chris Lee 2004-09-24 17:25:03 EDT
Created attachment 104294 [details]
Output of yum crashing on update

This is what I get from yum with a broken package. (This is an example trimmed
to show the problem - with any single broken package in a larger update, the
same results occur.)
Comment 2 Seth Vidal 2004-09-26 15:39:11 EDT
Could you check out yum cvs and tell me if this is fixed. I think it's
been fixed for a little while now.

Comment 3 Chris Lee 2004-09-28 17:10:19 EDT
I should note that the crash was apparently caused by GPG checking the
packages - if the package was unsigned, yum would crash. However,
setting gpgcheck=0 in my /etc/yum.conf made this particular issue go away.

I have updated to yum CVS and will test against it with the next
rawhide update.

Note You need to log in before you can comment on or make changes to this bug.