Bug 1335820 - Reversed (or previously applied) patch detected! Assume -R? [n]
Summary: Reversed (or previously applied) patch detected! Assume -R? [n]
Keywords:
Status: CLOSED DUPLICATE of bug 126342
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-13 09:55 UTC by Roland
Modified: 2016-05-13 12:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-13 12:20:35 UTC


Attachments (Terms of Use)

Description Roland 2016-05-13 09:55:00 UTC
Description of problem:
- None, I have only a question

Version-Release number of selected component (if applicable):
- 4.4.9-300

How reproducible:
- rpmbuild -ba kernel.spec

Dear sir / madam,

I am trying to build a kernel of linux version 4.4.10 (Long Term support kernel)
i have installed the 4.4.9 source rpm.
- rpm -i kernel-4.4.9-300.fc23.src.rpm

after that, and copying linux 4.4.10 ( repacked to 4.4 ) to the sources dir, and renamed patch 4.4.9.xz to 4.4.10.xz, i started the build.

The build fails by:
----------
[krusader@DELLFEDORA SPECS]$ rpmbuild -ba kernel.spec
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.RTuQDV
+ umask 022
+ cd /home/krusader/rpmbuild/BUILD
+ patch_command='patch -p1 -F1 -s'
++ find /home/krusader/rpmbuild/BUILD -maxdepth 1 -type d -name 'kernel-4.*'
++ grep -x -v /home/krusader/rpmbuild/BUILD/kernel-4.4.fc23
+ sharedirs=
+ :
+ '[' -d kernel-4.4.fc23 ']'
+ cd kernel-4.4.fc23
+ for i in 'linux-*'
+ '[' -d linux-4.4.10-300.fc23.x86_64 ']'
+ rm -rf deleteme.x86_64
+ mv linux-4.4.10-300.fc23.x86_64 deleteme-linux-4.4.10-300.fc23.x86_64
+ cd ..
+ '[' '!' -d kernel-4.4.fc23/vanilla-4.4 ']'
+ cd kernel-4.4.fc23
+ cp -al vanilla-4.4 linux-4.4.10-300.fc23.x86_64
+ rm -rf deleteme-linux-4.4.10-300.fc23.x86_64
+ cd linux-4.4.10-300.fc23.x86_64
+ '[' '!' -d .git ']'
+ git init
Initialized empty Git repository in /home/krusader/rpmbuild/BUILD/kernel-4.4.fc23/linux-4.4.10-300.fc23.x86_64/.git/
+ git config user.email kernel-team@fedoraproject.org
+ git config user.name 'Fedora Kernel Team'
+ git config gc.auto 0
+ git add .
+ git commit -a -q -m baseline
+ xzcat /home/krusader/rpmbuild/SOURCES/patch-4.4.10.xz
+ patch -p1 -F1 -s
Reversed (or previously applied) patch detected!  Assume -R? [n]
-------------
What do i have to press after :
Reversed (or previously applied) patch detected!  Assume -R? [n]  ?
or what do i have to do in order to start the build?

I do know that 4.4.10 will never hit the repo's, but i wanted to learn more about kernel building.

Kind regards

Comment 1 Josh Boyer 2016-05-13 12:20:35 UTC
(In reply to Roland from comment #0)
> Description of problem:
> - None, I have only a question

Questions are better sent to the fedora kernel list (kernel@lists.fedoraproject.org)

> Version-Release number of selected component (if applicable):
> - 4.4.9-300
> 
> How reproducible:
> - rpmbuild -ba kernel.spec
> 
> Dear sir / madam,
> 
> I am trying to build a kernel of linux version 4.4.10 (Long Term support
> kernel)
> i have installed the 4.4.9 source rpm.
> - rpm -i kernel-4.4.9-300.fc23.src.rpm
> 
> after that, and copying linux 4.4.10 ( repacked to 4.4 ) to the sources dir,
> and renamed patch 4.4.9.xz to 4.4.10.xz, i started the build.
> 
> The build fails by:
> ----------
> [krusader@DELLFEDORA SPECS]$ rpmbuild -ba kernel.spec
> Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.RTuQDV
> + umask 022
> + cd /home/krusader/rpmbuild/BUILD
> + patch_command='patch -p1 -F1 -s'
> ++ find /home/krusader/rpmbuild/BUILD -maxdepth 1 -type d -name 'kernel-4.*'
> ++ grep -x -v /home/krusader/rpmbuild/BUILD/kernel-4.4.fc23
> + sharedirs=
> + :
> + '[' -d kernel-4.4.fc23 ']'
> + cd kernel-4.4.fc23
> + for i in 'linux-*'
> + '[' -d linux-4.4.10-300.fc23.x86_64 ']'
> + rm -rf deleteme.x86_64
> + mv linux-4.4.10-300.fc23.x86_64 deleteme-linux-4.4.10-300.fc23.x86_64
> + cd ..
> + '[' '!' -d kernel-4.4.fc23/vanilla-4.4 ']'
> + cd kernel-4.4.fc23
> + cp -al vanilla-4.4 linux-4.4.10-300.fc23.x86_64
> + rm -rf deleteme-linux-4.4.10-300.fc23.x86_64
> + cd linux-4.4.10-300.fc23.x86_64
> + '[' '!' -d .git ']'
> + git init
> Initialized empty Git repository in
> /home/krusader/rpmbuild/BUILD/kernel-4.4.fc23/linux-4.4.10-300.fc23.x86_64/.
> git/
> + git config user.email kernel-team@fedoraproject.org
> + git config user.name 'Fedora Kernel Team'
> + git config gc.auto 0
> + git add .
> + git commit -a -q -m baseline
> + xzcat /home/krusader/rpmbuild/SOURCES/patch-4.4.10.xz
> + patch -p1 -F1 -s
> Reversed (or previously applied) patch detected!  Assume -R? [n]
> -------------
> What do i have to press after :
> Reversed (or previously applied) patch detected!  Assume -R? [n]  ?
> or what do i have to do in order to start the build?
> 
> I do know that 4.4.10 will never hit the repo's, but i wanted to learn more
> about kernel building.

Don't repack the whole tarball.  Download the patch-4.4.10.xz file from kernel.org and use that in place of patch-4.4.9.xz.

Further discussion should happen on the list please.

*** This bug has been marked as a duplicate of bug 126342 ***


Note You need to log in before you can comment on or make changes to this bug.