Bug 1335873 - UintArgs.h is missing from /usr/include/Pegasus/Common
Summary: UintArgs.h is missing from /usr/include/Pegasus/Common
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tog-pegasus
Version: 7.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Vitezslav Crhonek
QA Contact: Alois Mahdal
URL:
Whiteboard:
Depends On:
Blocks: 1380364
TreeView+ depends on / blocked
 
Reported: 2016-05-13 12:31 UTC by Tomasz Kepczynski
Modified: 2017-08-01 16:45 UTC (History)
2 users (show)

Fixed In Version: tog-pegasus-2.14.1-4.el7
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-08-01 16:45:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1969 0 normal SHIPPED_LIVE tog-pegasus bug fix update 2017-08-01 17:57:01 UTC

Description Tomasz Kepczynski 2016-05-13 12:31:01 UTC
Description of problem:
CIM client application which includes CIMClient.h header file reports compilation error:

In file included from ../Tests/MiscTester.cpp:42:0:
/usr/include/Pegasus/Client/CIMClient.h:48:37: fatal error: Pegasus/Common/UintArgs.h: No such file or directory
compilation terminated.

Version-Release number of selected component (if applicable):
tog-pegasus-devel-2.14.1-3.el7.x86_64
tog-pegasus-devel-2.14.1-3.el7.i686


How reproducible:
Always

Actual results:
Compilation fails.

Expected results:
Compilation successful.

Additional info:
There may be more missing files, please check rpm %files and %install sections.

Found on CentOS 7.2. Confirmed in stock RHEL 7.2 rpm package (tog-pegasus-devel-2.14.1-3.el7.x86_64.rpm) from Workstation-optional repository.

Comment 2 Vitezslav Crhonek 2016-05-18 08:19:53 UTC
It seems that just Pegasus/Common/UintArgs.h and Pegasus/Client/CIMEnumerationContext.h are missing when including "CIMClient.h".

But including various Pegasus's headers may lead to further errors... Checking %files and %install won't help here, because we ship all headers installed by upstream Makefile (actually more - also additional isolated headers requested through BZs like this one).

Are you willing to copy missing headers temporarily by hand directly from the tarball and let me know when you encounter next missing headers during the development of your CIM client application? I can add them within this BZ request.

Comment 3 Tomasz Kepczynski 2016-05-19 14:32:03 UTC
I've identified 2 files which are missing and needed for my project to build:
/usr/include/Pegasus/Common/UintArgs.h
/usr/include/Pegasus/Client/CIMEnumerationContext.h

Comment 4 Vitezslav Crhonek 2016-05-23 08:27:39 UTC
(In reply to Tomasz Kepczynski from comment #3)
> I've identified 2 files which are missing and needed for my project to build:
> /usr/include/Pegasus/Common/UintArgs.h
> /usr/include/Pegasus/Client/CIMEnumerationContext.h

Thank you.

Comment 6 Alois Mahdal 2017-06-03 00:28:48 UTC
Both files have been added in tog-pegasus-devel-2.14.1-4.el7.

Comment 7 errata-xmlrpc 2017-08-01 16:45:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1969


Note You need to log in before you can comment on or make changes to this bug.