Bug 1335876 - Trusted Forest Settings table disappears when switched between authentication modes.
Summary: Trusted Forest Settings table disappears when switched between authentication...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.5.5
Assignee: Harpreet Kataria
QA Contact: amogh
URL:
Whiteboard: ldap
Depends On: 1326499
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-13 12:35 UTC by John Prause
Modified: 2016-07-26 15:34 UTC (History)
7 users (show)

Fixed In Version: 5.5.5.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1326499
Environment:
Last Closed: 2016-07-26 15:34:27 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1488 normal SHIPPED_LIVE CFME 5.5.5 bug fixes and enhancement update 2016-07-26 19:28:27 UTC

Comment 3 CFME Bot 2016-06-13 18:39:38 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=a2ec6c596b5ff1b2ccd6ca51b42a92c15f2b9d7f

commit a2ec6c596b5ff1b2ccd6ca51b42a92c15f2b9d7f
Merge: 3e03d5c 313d8c2
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Jun 13 13:30:46 2016 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Jun 13 13:30:46 2016 -0400

    Merge branch '55z_pr_8658' into '5.5.z'
    
    Display Forest Entries box when switching mode back to LDAP/LDAPS
    
    - Fixed code to show Forest Entries box when switching back to LDAP/LDAPS mode
    - Added spec test to verify fix
    - Fixed alignment of icons in Forest Entries box
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1326499
    https://bugzilla.redhat.com/show_bug.cgi?id=1335876
    (cherry picked from commit 4e40366)
    
    @dclarizi please review, this is clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/8658
    
    See merge request !936

 app/controllers/ops_controller/settings/common.rb  |  2 ++
 app/views/ops/_ldap_forest_entries.html.haml       |  4 +--
 .../ops_controller/settings/common_spec.rb         | 41 ++++++++++++++++++++++
 3 files changed, 44 insertions(+), 3 deletions(-)

Comment 4 CFME Bot 2016-06-13 18:40:12 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=313d8c2ae35a9dbc4f1920a2e486a734d0e44430

commit 313d8c2ae35a9dbc4f1920a2e486a734d0e44430
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu May 12 12:18:43 2016 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri May 13 09:10:04 2016 -0400

    Display Forest Entries box when switching mode back to LDAP/LDAPS
    
    - Fixed code to show Forest Entries box when switching back to LDAP/LDAPS mode
    - Added spec test to verify fix
    - Fixed alignment of icons in Forest Entries box
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1326499
    https://bugzilla.redhat.com/show_bug.cgi?id=1335876
    (cherry picked from commit 4e40366)

 app/controllers/ops_controller/settings/common.rb  |  2 ++
 app/views/ops/_ldap_forest_entries.html.haml       |  4 +--
 .../ops_controller/settings/common_spec.rb         | 41 ++++++++++++++++++++++
 3 files changed, 44 insertions(+), 3 deletions(-)

Comment 6 amogh 2016-07-15 15:13:57 UTC
issue not reproducible in 5.5.5.2.20160712144556_629f93b. Trusted forest table displayed correctly.

Comment 8 errata-xmlrpc 2016-07-26 15:34:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html


Note You need to log in before you can comment on or make changes to this bug.