Bug 1335914 - Disable the MD5 as a signing algorithm in openssl library
Disable the MD5 as a signing algorithm in openssl library
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openssl (Show other bugs)
6.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomas Mraz
Stanislav Zidek
Mirek Jahoda
:
Depends On:
Blocks: 1343211 1335911
  Show dependency treegraph
 
Reported: 2016-05-13 10:22 EDT by Nikos Mavrogiannopoulos
Modified: 2017-03-21 06:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: openssl-1.0.1e-51.el6
Doc Type: Deprecated Functionality
Doc Text:
MD5, MD4, and SHA0 as the signing algorithms in *OpenSSL* disabled With this update, support for the verification of MD5, MD4, and SHA0 signatures in certificates, Certificate Revocation Lists (CRL) and message signatures is removed. The system administrator can enable MD5, MD4, or SHA0 support by modifying the "LegacySigningMDs" option in the `etc/pki/tls/legacy-settings` policy configuration file, for example: echo 'LegacySigningMDs md5' >> /etc/pki/tls/legacy-settings You can also enable the MD5 verification by setting the "OPENSSL_ENABLE_MD5_VERIFY" environment variable.
Story Points: ---
Clone Of:
: 1335915 (view as bug list)
Environment:
Last Closed: 2017-03-21 06:11:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0660 normal SHIPPED_LIVE openssl bug fix update 2017-03-21 08:33:58 EDT

  None (edit)
Description Nikos Mavrogiannopoulos 2016-05-13 10:22:41 EDT
RHEL includes several cryptographic components who's security doesn't remain constant over time. Algorithms such as (cryptographic) hashing and encryption typically have a lifetime after which they are considered either too risky to use or plain insecure. That would mean we need to phase out such algorithms from the default settings, or completely disable if they could cause irreparable issue. 

This bug is about disabling the MD5 algorithm from the OpenSSL library, while at the same hand providing a configuration method for MD5 to be allowed when needed.

For future extensibility in RHEL-7 it is recommended for any introduced configuration method to be re-usable for future algorithm or parameter deprecation (e.g., SHA1 or less than 1024-bit RSA/DH parameters), and ideally part of upstream.
Comment 2 Tomas Mraz 2016-10-05 05:26:40 EDT
I've found that it was possible to verify also certificates using MD2, MD4, and SHA0, I've disabled these together with MD5.

The system administrator can re-enable some of them with

echo 'LegacySigningMDs md5 md4' >> /etc/pki/tls/legacy-settings

For MD5 it is also possible to enable it by setting environment variable OPENSSL_ENABLE_MD5_VERIFY to any value (same method as in RHEL-7).
Comment 10 errata-xmlrpc 2017-03-21 06:11:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0660.html

Note You need to log in before you can comment on or make changes to this bug.