Bug 1335935 - Host list links to an incorrect host details for failed or initializing hosts
Summary: Host list links to an incorrect host details for failed or initializing hosts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 2
Assignee: kamlesh
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-05-13 14:53 UTC by Martin Bukatovic
Modified: 2016-08-23 19:50 UTC (History)
5 users (show)

Fixed In Version: rhscon-ui-0.0.46-1.el7scon.noarch
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:50:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 0 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Martin Bukatovic 2016-05-13 14:53:54 UTC
Description of problem
======================

All Host items (in a list on Hosts page) in "Failed" or "Initializing" state
points to the same Host details page: details page of one particular failed
hosts is shown no matter which host name link is clicked on.

Version-Release
===============

rhscon-core-0.0.16-1.el7scon.x86_64
rhscon-ceph-0.0.13-1.el7scon.x86_64
rhscon-ui-0.0.29-1.el7scon.noarch

rhscon-agent-0.0.6-1.el7scon.noarch

How reproducible
================

100 %

Steps to Reproduce
==================

1. Install RHSC 2.0 following the documentation.
2. Prepare some machines for the future cluster. You would need at lest 6
   machines (we need to break at lest 3 machines in the next step).
3. Run "Accept All", but kill (virsh destroy) 3 machines while the "Accepting
   Host" tasks are still running.
   (This is necessary for us to have multiple hosts in a failed state).
4. Go to Hosts page and see that all of your machines are in "Ok" state, with
   the exception of 3 machines you destroyed in the previous step on purpose,
   which are in "Failed" state.
5. Every Host item contains a html link to Host Details page. Try to click
   on every host in Failed state to get to it's Host Details page.

Actual results
==============

For all hosts in "Failed" state, name of the host links to the same url:

~~~
http://usm.example.com:8080/#/hosts/00000000-0000-0000-0000-000000000000
~~~

(this applies to any Host in "Failed" or "Initializing" state)

Then you try to click on the name link, again for all hosts in "Failed" state
and observe that every time, you end up on the same page (Host Details of one
of failed nodes are shown).

Expected results
================

For every host in a failed or initializing state, host name link should get
you to the details of this particular host.

Moreover if the data for the host are not available, this should be
communicated to the user instead of presenting and empty Host Details template
with empty or zero values everywhere.

Comment 2 Nishanth Thomas 2016-05-14 04:42:51 UTC
Host link to be enabled only if node in the 'active' state. There is no point showing directing to 'host details' for host which is failed or stuck in 'initialization' state as no details available

Comment 4 Martin Kudlej 2016-07-22 10:59:38 UTC
This is fixed in
ceph-ansible-1.0.5-27.el7scon.noarch
ceph-installer-1.0.14-1.el7scon.noarch
rhscon-ceph-0.0.33-1.el7scon.x86_64
rhscon-core-0.0.34-1.el7scon.x86_64
rhscon-core-selinux-0.0.34-1.el7scon.noarch
rhscon-ui-0.0.48-1.el7scon.noarch

Comment 6 errata-xmlrpc 2016-08-23 19:50:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.