Bug 133599 - Automatic proxy settings don't work.
Summary: Automatic proxy settings don't work.
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-25 00:30 UTC by Robert Walsh
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-25 00:35:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Walsh 2004-09-25 00:30:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7)
Gecko/20040904 Firefox/0.9.3

Description of problem:
I have a .pac file that allows me to look at web sites at work over a
secure ssh tunnel.  The file looks like this:

function FindProxyForURL(url, host)
{
    if (dnsDomainIs(host, ".WHATEVER.com") ||
        dnsDomainIs(host, ".WHEREVER.com"))
        return "PROXY localhost:3128";
    else
        return "DIRECT";
}

(I've changes the real domain names).  This worked fine on an earlier
version of firefox I was using, but for the new version that ships
with FC3-test2, it doesn't get used at all - request for host names
ending in .WHATEVER.com or .WHEREVER.com are handled DIRECT instead.

Actually, it looks like this file is being completely ignored, because
if I replace the "DIRECT" setting with "PROXY localhost:1234" (which
is a pointer to a proxy that doesn't actually exist) then it doesn't
give an error when I try to load regular (i.e. non-work) web pages.

The earlier version of firefox I used was the 0.9.3 version from the
dag rpm repository.  I had to blow away the .mozilla directory from
that version in order to get the FC3-test2 version to work properly
(but that's for another bug report) and I noticed this problem when I
was recreating my setup.

If I do a manual connection and tell it to use localhost, port 3128
for all HTTP requests, it works fine, but I obviously don't want to
see all my web requests going through work...


Version-Release number of selected component (if applicable):
firefox-0.9.3-8

How reproducible:
Always

Steps to Reproduce:
1. Create a .pac file similar to the above that just points at a
non-existent proxy.
2. Tell firefox to use this file.
3. Try access a web page.


Actual Results:  Web page will actually load, despite the fact that
the proxy doesn't exist.

Expected Results:  It should give an error about not being able to
contact the proxy.

Additional info:

Comment 1 Robert Walsh 2004-09-25 00:35:38 UTC
Crap - my bad.  I had a braino in the configuration dialog box.  I was
using the pathname raw, without "file://" stuck in front of it. 
Apologies.  Much embarrassment.


Note You need to log in before you can comment on or make changes to this bug.