This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 133604 - init scripts can't find dbus pid file
init scripts can't find dbus pid file
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-09-25 01:07 EDT by Nick Jones
Modified: 2013-03-13 00:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 13:06:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nick Jones 2004-09-25 01:07:14 EDT
From Bugzilla Helper:
User-Agent: Opera/7.52 (X11; Linux i686; U)  [en]

Description of problem:
Dbus places it's pid in the file file /var/run/dbus/pid but the 
initscripts functions (invoked by dbus's own init.d script) expect to 
find it in /var/run/messagebus

Suggestion that worked for me:
add --system-wide-pid-file=/var/run/messagebus.pid to configure 
options in spec file.
With this change, /var/run/messagebus.pid is recognised as the pid 
file, and is cleaned up after the service is stopped (something that 
dbus doesn't seem to do itself)

Version-Release number of selected component (if applicable):
dbus-0.22-9

How reproducible:
Always

Steps to Reproduce:
1./etc/init.d/messagebus stop

    

Actual Results:  [FAILED]

Expected Results:  [  OK  ]

Additional info:
Comment 1 John (J5) Palmieri 2004-09-25 02:38:46 EDT
Works for me.  Dbus always created /var/run/messagebus.pid on my
machine.  Did you upgrade to test 2 or is it a fresh install.  If you
did upgrade, from what version?
Comment 2 Steve Grubb 2004-09-25 11:18:00 EDT
I think this is a duplicate of: Bug 132436 - which is now closed.

The real problem is that configure does not see the
/etc/redhat-release file and decides its not a red hat system. Rather
than have a system-wide-pid-file=/var/run/messagebus.pid option, it
needs to have an option to say this is a red hat system that sets the
default value for the same variable set when it looks for the
/etc/redat-release file. 

There may be other decisions the configure script makes based on the
os variable. Fixing each one with an override is inefficient.
Comment 3 John (J5) Palmieri 2004-09-27 13:06:06 EDT
Nick Jones hasn't replyed back so closing this as works for me.

Note You need to log in before you can comment on or make changes to this bug.