This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 133606 - kernel spontaneously reboots after login prompt appears
kernel spontaneously reboots after login prompt appears
Status: CLOSED DUPLICATE of bug 132719
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-25 03:12 EDT by Reuben Farrelly
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2004-09-25 03:12:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
I've not been running fedora kernels for a while but today fired up 
the latest one in -devel (entire system is up to date with devel).  I 
usually run -mm and vanilla kernel.org kernels.

The system boots up normally, and all looks well, however 5-10 
seconds after the system reaches it's final runlevel 3 and the login 
prompt appears, it falls over and returns to the bios screen.

This problem had not occurred with any other kernel I have ever 
tried, including the vanilla 2.6.8.1 from kernel.org.

The box passed with 100% on memtest, on a 4 hour run.

It is an Intel P4-2.8, with HT enabled, on a Gigabyte 8IPE1000-Pro2 
board (intel 865 chipset).  I am running reiserfs on a raid1 set of 
disks.

I've booted up with  maxcpus=1  and noapic   and the problem remains.

Version-Release number of selected component (if applicable):
2.6.8-1.584

How reproducible:
Always

Steps to Reproduce:
1. Boot up box
    

Actual Results:  Box reboots without warning or logging anything 
in /var/log/messages

Expected Results:  Box ought to have been stable ;-)

Additional info:

Box has latest BIOS installed, kernel is not tainted.  I am not 
overclocking the system.
Comment 1 Reuben Farrelly 2004-09-25 03:13:40 EDT
Kernel is the smp version.
Comment 2 Reuben Farrelly 2004-09-25 03:41:15 EDT
Box also spontaneously reboots even if only run up to single user 
mode :(
Comment 3 Arjan van de Ven 2004-09-25 03:45:11 EDT
can you see if the i810_tco module is getting loaded? that's the
hardware watchdog your system has.....
Comment 4 Reuben Farrelly 2004-09-25 06:23:11 EDT
Yep, the i8xx_tco module is there...
Comment 5 Arjan van de Ven 2004-09-25 06:26:12 EDT
if you remove it (say from the filesystem) the reboots should go away..
Comment 6 Reuben Farrelly 2004-09-25 06:34:22 EDT
I've had 14 minutes of uptime with that kernel now, I never got 
anywhere near that before, so looks pretty likely that is the problem.

What is the workaround for this, is it to edit modprobe.conf?
Comment 7 Bill Nottingham 2004-09-28 13:44:51 EDT

*** This bug has been marked as a duplicate of 132719 ***
Comment 8 Red Hat Bugzilla 2006-02-21 14:05:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.