Bug 1336084 - touchpad jitter (pointer noisy when slow)
Summary: touchpad jitter (pointer noisy when slow)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libinput
Version: 23
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-14 02:27 UTC by Andreas M. Kirchwitz
Modified: 2016-05-26 10:54 UTC (History)
2 users (show)

Fixed In Version: libinput-1.2.4-3.fc23 libinput-1.2.4-4.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-26 10:54:40 UTC
Type: Bug


Attachments (Terms of Use)
xinput devices and touchpad properties (3.51 KB, text/plain)
2016-05-14 02:29 UTC, Andreas M. Kirchwitz
no flags Details
evemu-describe for touchpad (3.90 KB, text/plain)
2016-05-14 02:31 UTC, Andreas M. Kirchwitz
no flags Details
evemu-record of jitter (98.19 KB, text/plain)
2016-05-14 02:33 UTC, Andreas M. Kirchwitz
no flags Details

Description Andreas M. Kirchwitz 2016-05-14 02:27:14 UTC
Description of problem:
Running regular GNOME3 on Fedora 23 (64 bit), the pointer movement on screen shows increased jitter when fingertip on touchpad operates at low speed or stands still. If I just press my fingertip on the touchpad (no movement at all), the pointer on screen does not stand still but randomly jumps around some pixels in all directions. In average, the pointer keeps its position but it clearly shows jitter (or noise, whatever this is called technically).

This makes it hard to hit small objects on screen. Scrollbars are difficult to handle. Any exact positioning is impossible.

On the web, there are reports about this problem for years (long before libinput), and sometimes touchpad drivers offer configuration to smooth that noisy input data (eg, synclient HorizHysteresis/VertHysteresis).

Version-Release number of selected component (if applicable):
libinput-1.2.4-1.fc23.x86_64
(all official updates as of 2016-05-13)

How reproducible:
Always.

Steps to Reproduce:
1. Press fingertip on touchpad (and hold still).
2. Watch pointer on screen.
3. Pointers constantly jumps around some pixels on all directions.

Actual results:
Pointer on screen is jumpy/noisy, shows jitter (for no operations as well as slow operations on touchpad).

Expected results:
If the fingertip on touchpad doesn't move, the pointer on screen shouldn't move as well. Also slow movements shouldn't be jumpy.

Additional info:
See attachment for additional details (maybe helpful).

Comment 1 Andreas M. Kirchwitz 2016-05-14 02:29:48 UTC
Created attachment 1157444 [details]
xinput devices and touchpad properties

Output of "xinput" and "xinput list-props 12" (touchpad).

Comment 2 Andreas M. Kirchwitz 2016-05-14 02:31:22 UTC
Created attachment 1157445 [details]
evemu-describe for touchpad

Output of "evemu-describe" for touchpad device.

Comment 3 Andreas M. Kirchwitz 2016-05-14 02:33:32 UTC
Created attachment 1157446 [details]
evemu-record of jitter

Output of "evemu-record" (for touchpad device) while holding still with the fingertip on touchpad for some seconds.

Comment 4 Peter Hutterer 2016-05-19 04:46:22 UTC
give this one a try please:
http://koji.fedoraproject.org/koji/taskinfo?taskID=14162802

you'll need to restart or at least run sudo udevadm trigger to make sure the LIBINPUT_MODEL_WOBBLY_TOUCHPAD appears in the udevadm info output.

Comment 5 Andreas M. Kirchwitz 2016-05-19 11:48:10 UTC
That libinput package works wonders! The pointer on screen is rock-solid when I stand still with my finger on the touchpad. And if I (intentionally) start to move my finger slightly in a direction the pointer follows properly (without any added jitter).

Looks perfect to me. Thanks a lot!

FYI: LIBINPUT_MODEL_WOBBLY_TOUCHPAD appears for exactly one /dev/input device
(udevadm info) which refers to the touchpad (so I guess it works as intended):

P: /devices/platform/i8042/serio1/input/input6/event6
N: input/event6
S: input/by-path/platform-i8042-serio-1-event-mouse
E: DEVLINKS=/dev/input/by-path/platform-i8042-serio-1-event-mouse
E: DEVNAME=/dev/input/event6
E: DEVPATH=/devices/platform/i8042/serio1/input/input6/event6
E: ID_INPUT=1
E: ID_INPUT_TOUCHPAD=1
E: ID_PATH=platform-i8042-serio-1
E: ID_PATH_TAG=platform-i8042-serio-1
E: ID_SERIAL=noserial
E: LIBINPUT_DEVICE_GROUP=11/2/8/300:isa0060/serio1
E: LIBINPUT_MODEL_ALPS_TOUCHPAD=1
E: LIBINPUT_MODEL_FIRMWARE_VERSION=300
E: LIBINPUT_MODEL_WOBBLY_TOUCHPAD=1
E: MAJOR=13
E: MINOR=70
E: SUBSYSTEM=input
E: USEC_INITIALIZED=14950753

Comment 6 Fedora Update System 2016-05-20 01:43:33 UTC
libinput-1.2.4-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fac498468f

Comment 7 Fedora Update System 2016-05-21 02:26:41 UTC
libinput-1.2.4-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fac498468f

Comment 8 Kadir 2016-05-21 18:03:15 UTC
Hi, I have a Dell Latitude E6320 and I too experience this bug. I already tried installing libinput-1.2.4-3.fc23, the bug is still there. Here is my udevadm info /dev/input/event8 output:

P: /devices/platform/i8042/serio1/input/input6/event8
N: input/event8
S: input/by-path/platform-i8042-serio-1-event-mouse
E: DEVLINKS=/dev/input/by-path/platform-i8042-serio-1-event-mouse
E: DEVNAME=/dev/input/event8
E: DEVPATH=/devices/platform/i8042/serio1/input/input6/event8
E: ID_INPUT=1
E: ID_INPUT_TOUCHPAD=1
E: ID_PATH=platform-i8042-serio-1
E: ID_PATH_TAG=platform-i8042-serio-1
E: ID_SERIAL=noserial
E: LIBINPUT_DEVICE_GROUP=11/2/8/300:isa0060/serio1
E: LIBINPUT_MODEL_ALPS_TOUCHPAD=1
E: LIBINPUT_MODEL_FIRMWARE_VERSION=300
E: MAJOR=13
E: MINOR=72
E: SUBSYSTEM=input
E: USEC_INITIALIZED=4988978

I don't have the LIBINPUT_MODEL_WOBBLY_TOUCHPAD output

Comment 9 Fedora Update System 2016-05-23 04:54:31 UTC
libinput-1.2.4-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-edfbda8930

Comment 10 Kadir 2016-05-23 05:37:24 UTC
This latest build (libinput-1.2.4-4.fc23) fixed the problem! I now have the following output from udevadm info:

P: /devices/platform/i8042/serio1/input/input6/event8
N: input/event8
S: input/by-path/platform-i8042-serio-1-event-mouse
E: DEVLINKS=/dev/input/by-path/platform-i8042-serio-1-event-mouse
E: DEVNAME=/dev/input/event8
E: DEVPATH=/devices/platform/i8042/serio1/input/input6/event8
E: ID_INPUT=1
E: ID_INPUT_TOUCHPAD=1
E: ID_PATH=platform-i8042-serio-1
E: ID_PATH_TAG=platform-i8042-serio-1
E: ID_SERIAL=noserial
E: LIBINPUT_DEVICE_GROUP=11/2/8/300:isa0060/serio1
E: LIBINPUT_MODEL_ALPS_TOUCHPAD=1
E: LIBINPUT_MODEL_FIRMWARE_VERSION=300
E: LIBINPUT_MODEL_WOBBLY_TOUCHPAD=1
E: MAJOR=13
E: MINOR=72
E: SUBSYSTEM=input
E: USEC_INITIALIZED=4962331


Thank you!

Comment 11 Fedora Update System 2016-05-24 01:24:26 UTC
libinput-1.2.4-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-05-24 02:52:34 UTC
libinput-1.2.4-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-edfbda8930

Comment 13 Fedora Update System 2016-05-26 10:54:37 UTC
libinput-1.2.4-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.