Bug 133620 - USB DVD install source impossible despite usb-storage loading and recognizing device
USB DVD install source impossible despite usb-storage loading and recognizing...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-25 05:54 EDT by C.H.
Modified: 2015-01-04 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 20:31:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description C.H. 2004-09-25 05:54:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10

Description of problem:
It is not possible to use a USB attached DVD to install FC3T2
despite the device being recognized and usb-storage module loaded.
No apparent possibility of using "cdrom install",
"hard disc install", "select driver", or "use a driver disc" would
permit this very desirable operation to succeed.

The desired fixes to make installation easier are:
1 Support USB / firewire attached CD/DVD installs so they "just work"
when one picks "CDROM" media source.

2 Support installation from "expanded" media trees (e.g. same
layout as for NFS / HTTP / FTP install) for "Hard disk" based 
install type. When one has the burned DVD in the machine to
be installed, it's a LOT easier to copy the FILE TREE to another
HDD partition than to copy the ISO image which can't easily be read
from the burned DVD on non UNIX OSs.

3 Support NTFS partition "hard disk install".

4 Support "shared ISO image" based HTTP / FTP / NFS installs
(e.g. give the user the option to share EITHER the ISO DVD image
OR the file trees copied from it over HTTP/FTP/NFS).

5 Support CIFS / SAMBA networked install.

6 Support dropping to a shell early in the installer with the
tools present to permit one to mkfs an ext2/3 fs, mount
local HDD / DVD drives, mount remote NFS, or FTP / curl / wget /
fetch from remote HTTP/FTP servers.  If I'd been able to get a shell
I could have probably 'worked around' the installer limitation which
prevented recognizing the DVD media source by copying the files to
a HDD partition or mounting the drive manually et. al.

7 Support install media source of USB-Hard disc under "hard disc"
based install, and support ext2,ext3,reiser,ufs,ffs,ntfs,fat
partitions on such hard drives, and the ability to have either
the ISO images or the "file trees" there for the install source.

Bug details: 
anaconda installer
Select: "To install or upgrade in graphical mode, press the <ENTER> key."

* "Installation Method"
What type of media contains the packages to be installed?
     Local CDROM
     Hard drive
     NFS inage
     FTP
     HTTP

     * Pick "Local CDROM" ->
	    No driver found
	    Unable to find any devices of the type
	    needed for this installation type.
	    Would you like to manually select your driver or use a driver disk?
	    [Select driver], [Use a driver disk] [Back]


* Use F3 / F4 to view log information: 
----------------------------------------------------------------------
Graphical install logs w/o user interaction:

F3:
	* found USB controller uhci-hcd
	* modules to insert
	* load module set done
	* waiting for usb to become stable...
	* 4 seconds
	* modules to insert hid keybdev  usb-storage
	* loaded usb-storage from /modules/modules.cgz
	* module(s) hid keybdev  not found
	* inserted /tmp/usb-storage.ko
	* load module set done
	* no firewire controller found
	* no pcic controller found
	* probing buses
	* finished bus probing
	* modules to insert r8169
	* loaded r8169 from /modules/modules.cgz
	* inserted /tmp/r8169.ko
	* load module set done
	* got to setupCdrom without a CD device

F4:

	<6> Initializing USB Mass Storage driver...
	<6> scsi0 : SCSI emulation for USB Mass Storage devices
	<5> Vendor: Revoltec  Model: USB/IDE Bridge (  Rev: 0103
	<5> Type  : Direct-Access		       ANSI SCSI revision: 02 
	<5> SCSI device sda: 2295104 2048-byte hdwr sectors (4700 MB)
	<4> sda: test WP failed, assume Write Enabled
	<3> sda: assuming drive cache: write through
	<6> sda: unknown partition table
	<5> Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
	<7> USB Mass Storage device found at 2
	<6> usbcore: registered new driver usb-storage
	<6>USB Mass Storage support registered.

----------------------------------------------------------------------
This was tested on X86_64, using a ME-320U2 type USB2<->IDE
enclosure and an enclosed IDE DVD+RW, though I believe the limitations
are applicable to i386 and other kinds of USB (maybe
firewire too?) attached CD/DVD/HDD units.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.attempt to install from USB connected DVD drive.
2.
3.
    

Actual Results:  No possibility to install FC3T2 X96_64 from USB
connected DVD-RW
even though usb-storage module is loaded, and the device is
recognized. 



Expected Results:  Option to install from USB connected DVD-RW.
It should work transparently and as well as a IDE DVD drive.


Additional info:

Yes, I'm aware of the "oversized" x86_64 DVD image for
FC3T2 problem.  The DVD in question was somewhat "truncated"
and corrupted because of the image being too big for the disc,
however the media was mounted in LINUX after burning, and MD5sums
made of every file on the medium, and the only effected files were
SRPMS not used for the installation, and no "filesystem errors"
were reported in the mounting / IO operations.  The problem seems
to be one of just not attempting to "look for" /dev/sda et. al.
connected DVD/CD roms.
Comment 1 C.H. 2004-09-25 10:45:26 EDT
From the original poster -- I was getting ready to do a NFS install
so I rebooted (with a similar but different model USB-DVD+RW drive
connected this time), and noticed that this time the system thought 
it had a CDROM and the install proceeded correctly.

There's something about one of my two USB2.0 DVD+RW units that
FC3T2 doesn't like.  They're both in similar USB to IDE bridge
enclosures.  

The one drive that installs / works fine shows up as a
Vendor: __NEC Model: DVD+RW ND-1000A Rev: 1.01
Type CD-ROM  ANSI SCSI Revision: 02.

The drive that doesn't work for FC3T2 installs and also
(I now find) doesn't work as a CD/DVD in the installed FC3T2 X86_64
just shows up as:
Vendor: Revoltec  Model: USB/IDE Bridge (Rev: 0103
Type: Direct-Access  ANSI SCSI Revision: 02
From my notes it's probably an OEMed BTC DRW1008 DVD+/- RW
single layer unit, though it's retailed as an IOMAGIC IDVDRW8D.
 
So it isn't even recognizing it as a CD/DVD type device but is seeing
the USB IDE bridge enclosure itself I guess.  I have used both of
these USB DVD units successfully under SUSE 9.0 and Windows.
The firmware in the one that *DOES NOT* work is a bit stale, though
it has never totally failed to work / be recognized by other OSs.
I'll try to update its firmware and see what that may do.

Though the USB enclosures are similar, there could be differences
in the firmware and chipset since the two boxes were purchased
several months apart and from different retailers though they're
similar basic sorts of ME-320-U2 units.. When I've taken them apart
in the past I think they usually have an ALI USB to IDE bridge chip,
though I don't know about this particular one.  I'll look when I
open it to change the DVD+/-RW unit's firmware.

So instead of a "general problem" with USB DVD units F3CT2 seems
to have a problem with a certain set of them and not others.
I'm glad the install worked with the other (older) unit.
Comment 2 Bill Nottingham 2004-09-28 14:25:05 EDT
It's showing up as a removable hard disk; ergo, it won't be seen as a
'CD' device.
Comment 3 Tom Duffy 2005-03-09 17:37:16 EST
I am trying to install RHEL 4 AS off of my USB 2.0 DVD+-RW and it does not show
up as a hard disk or as a CDROM -- I can't install of it.
Comment 4 Tom Duffy 2005-03-09 18:01:12 EST
previous post: s/install of/install off of/

I also just tested FC3 Final and it has the same problem.

This is the DVD drive I am trying (as shows on a booted kernel)

  Vendor: _NEC      Model: DVD_RW ND-3520A   Rev: 1.04
  Type:   CD-ROM                             ANSI SCSI revision: 00
usb-storage: device scan complete
sr0: scsi3-mmc drive: 48x/48x writer cd/rw xa/form2 cdda tray
Attached scsi CD-ROM sr0 at scsi2, channel 0, id 0, lun 0
Comment 5 Dave Jones 2005-07-15 15:49:58 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 6 Dave Jones 2005-10-02 20:31:40 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.