Bug 1336220 - dnf crashes
Summary: dnf crashes
Keywords:
Status: CLOSED DUPLICATE of bug 1245121
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 23
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-15 20:07 UTC by Thomas Köller
Modified: 2016-05-16 11:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-16 11:26:49 UTC
Type: Bug


Attachments (Terms of Use)

Description Thomas Köller 2016-05-15 20:07:25 UTC
Description of problem:

I was trying to obtain information about all transactions that modified a particular package (sane-backends), using the 'dnf history' command. This lead to a crash in dnf:

[root@sarkovy ~]# dnf -C history info sane-backends
Transaction ID : 96
Begin time     : Sat Nov 14 12:44:08 2015
Begin rpmdb    : 2453:529c9c1fd6af1d58d96b5b9a78f5249baaec29db
End time       :            13:55:08 2015 (71 minutes)
End rpmdb      : 2495:a1572c76df11469fe3cf9ee25231742c6a09479b
User           : System <unset>
Return-Code    : Success
Command Line   : --releasever=23 system-upgrade upgrade
Transaction performed with:
    Upgraded      dnf-1.1.3-1.fc22.noarch     @updates/22
    Upgraded      rpm-4.12.0.1-13.fc22.x86_64 @updates/22
Packages Altered:
    Upgraded   GConf2-3.2.6-11.fc22.x86_64                                                      (unknown)
    Upgrade           3.2.6-15.fc23.x86_64                                                      @@commandline

< shortened very long list of packages >

    Upgraded   sac-1.3-20.fc21.noarch                                                           (unknown)
    Upgrade        1.3-21.fc23.noarch                                                           @@commandline
Traceback (most recent call last):
  File "/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1096, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/__init__.py", line 1220, in run
    ret = self.output.historyInfoCmd(extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1536, in historyInfoCmd
    self._historyInfoCmd(tid, pats)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1674, in _historyInfoCmd
    self.historyInfoCmdPkgsAltered(old, pats)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1749, in historyInfoCmdPkgsAltered
    x, m, u = dnf.yum.packages.parsePackages([hpkg], pats)
  File "/usr/lib/python3.4/site-packages/dnf/yum/packages.py", line 76, in parsePackages
    exactmatch.update(pkgdict[command])
TypeError: unhashable type: 'YumHistoryPackageState'
[root@sarkovy ~]# 



Version-Release number of selected component (if applicable):
[root@sarkovy ~]# dnf --version
1.1.8
  Installed: dnf-0:1.1.8-1.fc23.noarch at 2016-04-13 21:31
  Built    : Fedora Project at 2016-04-07 07:30

  Installed: rpm-0:4.13.0-0.rc1.13.fc23.x86_64 at 2016-04-28 06:23
  Built    : Fedora Project at 2016-04-25 13:50


How reproducible:
Always, AFAICT.

Comment 1 Honza Silhan 2016-05-16 11:26:49 UTC

*** This bug has been marked as a duplicate of bug 1245121 ***


Note You need to log in before you can comment on or make changes to this bug.