Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1336235 - gnome-software 3.21.1-2.fc25 crashes on startup
Summary: gnome-software 3.21.1-2.fc25 crashes on startup
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-15 23:07 UTC by Kevin Fenzi
Modified: 2016-12-08 12:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-08 12:36:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Kevin Fenzi 2016-05-15 23:07:42 UTC
(gnome-software:5533): Gs-ERROR **: CSS parsing error: not a number

Thread 1 "gnome-software" received signal SIGTRAP, Trace/breakpoint trap.
0x00007ffff467428b in g_logv () from /lib64/libglib-2.0.so.0
(gdb) where
#0  0x00007ffff467428b in g_logv () from /lib64/libglib-2.0.so.0
#1  0x00007ffff46743ff in g_log () from /lib64/libglib-2.0.so.0
#2  0x00005555555a91cc in css_error ()
#3  0x00007ffff49413c5 in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#4  0x00007ffff4953412 in signal_emit_unlocked_R () from /lib64/libgobject-2.0.so.0
#5  0x00007ffff495c03f in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
#6  0x00007ffff495c41f in g_signal_emit () from /lib64/libgobject-2.0.so.0
#7  0x00007ffff637847b in _gtk_css_parser_error () from /lib64/libgtk-3.so.0
#8  0x00007ffff63790e0 in gtk_css_dimension_value_parse () from /lib64/libgtk-3.so.0
#9  0x00007ffff6387001 in parse_font () from /lib64/libgtk-3.so.0
#10 0x00007ffff638506a in gtk_css_shorthand_property_parse_value () from /lib64/libgtk-3.so.0
#11 0x00007ffff637bfaf in gtk_css_provider_load_internal () from /lib64/libgtk-3.so.0
#12 0x00007ffff637d132 in gtk_css_provider_load_from_file () from /lib64/libgtk-3.so.0
#13 0x00005555555a8cf3 in theme_changed ()
#14 0x00005555555a926c in gs_application_initialize_ui.part ()
#15 0x00005555555a9798 in gs_application_activate ()
#16 0x00007ffff49415f4 in _g_closure_invoke_va () from /lib64/libgobject-2.0.so.0
#17 0x00007ffff495bdb9 in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
#18 0x00007ffff495c41f in g_signal_emit () from /lib64/libgobject-2.0.so.0
#19 0x00007ffff4c3012d in g_application_real_local_command_line () from /lib64/libgio-2.0.so.0
#20 0x00007ffff4c30322 in g_application_run () from /lib64/libgio-2.0.so.0
#21 0x0000555555570bff in main ()

Comment 1 Richard Hughes 2016-05-25 10:59:34 UTC
If you can reproduce, I'd love the output of "gnome-software --verbose" 
Thanks!

Comment 2 Kevin Fenzi 2016-05-25 17:32:05 UTC
This seems to be fixed now... I can no longer repoduce with gnome-software-3.21.2-1.fc25.x86_64.

Feel free to close.

Comment 3 Jan Kurik 2016-07-26 04:59:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.


Note You need to log in before you can comment on or make changes to this bug.