Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1336271 - Installer should not ask which version number to install
Summary: Installer should not ask which version number to install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: ---
Assignee: Samuel Munilla
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-16 04:44 UTC by Vikram Goyal
Modified: 2017-03-08 18:26 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, atomic-openshift-installer would ask the user which version of OpenShift is to be installed because the installer handled multiple versions. Now the installer is specific to the version of OpenShift being installed and as such we no longer ask the user which version they wish to install.
Clone Of:
Environment:
Last Closed: 2016-10-03 14:52:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1983 0 normal SHIPPED_LIVE OpenShift Container Platform 3.3 atomic-openshift-utils bug fix update 2016-10-03 18:51:38 UTC

Description Vikram Goyal 2016-05-16 04:44:45 UTC
Using atomic-openshift-utils 3.0.89-1 I wanted to test a docs bug on a OSE 3.0 install.

From the menu options, it gave me a choice to install OSE 3.0. I choose that and proceeded with the installation which ended successfully. 

However, the installer actually installed 3.2. Output from command openshift version is:

openshift v3.2.0.44
kubernetes v1.2.0-36
etc 2.2.5

Either the option to install OSE 3.0 should be taken out, or the installer should only install 3.0 when selected.

Comment 1 Gan Huang 2016-05-16 05:23:06 UTC
The OSE version you choosed in installer should be matched with the repo in the instances to be installed.

That means if you choose OSE 3.0 install, the OSE repo on your instances to be installed should be 3.0 as well.

Could you show the OSE repo in the instances to be installed?

Comment 2 Vikram Goyal 2016-05-16 05:40:52 UTC
Hello Gan,

Thanks. I can confirm that my OSE repo was set to 3.2 instead of 3.0. I have changed it to point to 3.0.

However, even after that, the installer tries to install the 3.2 package (resulting all sorts of errors):

TASK: [openshift_common | Install the base package for versioning] ************ 
failed: [ose3-dev-master.usersys.redhat.com] => {"changed": true, "rc": 1, "results": ["Loaded plugins: product-id, search-disabled-repos, subscription-manager\n

Package openshift is obsoleted by atomic-openshift, trying to install atomic-openshift-3.2.0.44-1.git.0.a4463d9.el7.x86_64 instead

\nResolving Dependencies\n--> Running transaction check\n---> Package atomic-openshift.x86_64 0:3.2.0.44-1.git.0.a4463d9.el7 will be installed\n--> Processing Dependency: atomic-openshift-clients = 3.2.0.44-1.git.0.a4463d9.el7 for package: atomic-openshift-3.2.0.44-1.git.0.a4463d9.el7.x86_64\n--> Running transaction check\n---> Package atomic-openshift-clients.x86_64 0:3.2.0.44-1.git.0.a4463d9.el7 will be installed\n--> Finished Dependency Resolution\n\nDependencies Resolved\n\n================================================================================\n Package                  Arch   Version                        Repository\n                                                                           Size\n================================================================================\nInstalling:\n atomic-openshift         x86_64 3.2.0.44-1.git.0.a4463d9.el7   ose-devel  22 M\nInstalling for dependencies:\n atomic-openshift-clients x86_64 3.2.0.44-1.git.0.a4463d9.el7   ose-devel  10 M\n\nTransaction Summary\n================================================================================\nInstall  1 Package (+1 Dependent package)\n\nTotal download size: 32 M\nInstalled size: 183 M\nDownloading packages:\nDelta RPMs disabled because /usr/bin/applydeltarpm not installed.\n"]}
msg: http://download.eng.bos.redhat.com/rcm-guest/puddles/RHAOS/AtomicOpenShift/3.0/latest/x86_64/os/Packages/atomic-openshift-clients-3.2.0.44-1.git.0.a4463d9.el7.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article 

https://access.redhat.com/articles/1320623

If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.

http://download.eng.bos.redhat.com/rcm-guest/puddles/RHAOS/AtomicOpenShift/3.0/latest/x86_64/os/Packages/atomic-openshift-3.2.0.44-1.git.0.a4463d9.el7.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.


Error downloading packages:
  atomic-openshift-clients-3.2.0.44-1.git.0.a4463d9.el7.x86_64: [Errno 256] No more mirrors to try.
  atomic-openshift-3.2.0.44-1.git.0.a4463d9.el7.x86_64: [Errno 256] No more mirrors to try.

Comment 3 Gan Huang 2016-05-16 06:30:50 UTC
It works well in my test env. 

I suspect it's because of your pre-installed OSE 3.2 rpm packages.

I think you should try to uninstall the OSE env or re-create the instances, and start a clean installation.

Comment 4 Samuel Munilla 2016-05-18 12:01:52 UTC
Is there any update here? My reading of it seems like there is no actual bug in the installer code.

Comment 9 Brenton Leanhardt 2016-09-07 20:25:31 UTC
Now that we require the version of the installer to match the desired environment we should remove the version numbers from the choices.

Comment 12 liujia 2016-09-19 05:57:18 UTC
Verified on PR 2420, the version number has been removed from prompted info as follows:
Which variant would you like to install?


(1) OpenShift Container Platform
(2) Registry

Choose a variant from above:  [1]:

Comment 14 Anping Li 2016-09-20 10:02:12 UTC
Waiting for puddle to verify this bug.

Comment 15 liujia 2016-09-21 03:14:49 UTC
Version:
ansible-2.2.0-0.50.prerelease.el7.noarch
atomic-openshift-utils-3.3.25-1.git.0.56ee824.el7.noarch

Steps:
1, run an install
#atomic-openshift-installer install
 
Result:
1, After enter ssh user account, it will prompt u to choose variant as follows:
Which variant would you like to install?


(1) OpenShift Container Platform
(2) Registry

Choose a variant from above:  [1]: 1

The version numbers have been removed from choices.

Comment 17 errata-xmlrpc 2016-10-03 14:52:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1983


Note You need to log in before you can comment on or make changes to this bug.