Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1336284 - Worker dies with [Errno 5] Input/output error upon creation of entries at slave
Summary: Worker dies with [Errno 5] Input/output error upon creation of entries at slave
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.7.11
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Raghavendra G
QA Contact:
URL:
Whiteboard:
Depends On: 1325760 1334164
Blocks: 1311817 1336285 1348060
TreeView+ depends on / blocked
 
Reported: 2016-05-16 06:00 UTC by Raghavendra G
Modified: 2016-06-28 12:17 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.7.12
Doc Type: Bug Fix
Doc Text:
Clone Of: 1334164
: 1336285 (view as bug list)
Environment:
Last Closed: 2016-06-28 12:17:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-05-16 06:04:45 UTC
REVIEW: http://review.gluster.org/14348 (cluster/distribute: use a linked inode in directory heal codepath) posted (#1) for review on release-3.7 by Raghavendra G (rgowdapp@redhat.com)

Comment 2 Vijay Bellur 2016-05-16 06:10:32 UTC
REVIEW: http://review.gluster.org/14349 (cluster/distribute: heal layout in discover codepath too) posted (#1) for review on release-3.7 by Raghavendra G (rgowdapp@redhat.com)

Comment 3 Vijay Bellur 2016-06-22 13:21:12 UTC
COMMIT: http://review.gluster.org/14349 committed in release-3.7 by Kaushal M (kaushal@redhat.com) 
------
commit 568c74b6571bdd6272ed932f5d15285d8a18ed14
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Fri May 13 11:40:57 2016 +0530

    cluster/distribute: heal layout in discover codepath too
    
    Change-Id: Ic559c220a1f0051e531314d13940604e2dead08c
    BUG: 1336284
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/14349
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Kaushal 2016-06-28 12:17:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.