Bug 133631 - SET AUTOCOMMIT TO OFF is no longer supported
Summary: SET AUTOCOMMIT TO OFF is no longer supported
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: postgresql   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tom Lane
QA Contact: David Lawrence
URL: http://archives.postgresql.org/pgsql-...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-25 11:52 UTC by Ted Kaczmarek
Modified: 2013-07-03 03:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-25 16:57:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ted Kaczmarek 2004-09-25 11:52:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
SET AUTOCOMMIT TO OFF is no longer supported. This functionality works
fine with postgresql-7.3.4-3. 

Version-Release number of selected component (if applicable):
postgresql-jdbc-7.4.5-2

How reproducible:
Always

Steps to Reproduce:
1.Install any java app that uses SET AUTOCOMMIT TO OFF
2.Run process that tries to SET AUTOCOMMIT TO OFF
3.
    

Actual Results:  java.sql.SQLException: ERROR:  SET AUTOCOMMIT TO OFF
is no longer
supported

Expected Results:  No error

Additional info:

Appears the postgres guys may have resolved this, but you guys would
have better access than I :-)

You may also want to the separate postgresql components to bugzilla.

Comment 1 Tom Lane 2004-09-25 16:57:02 UTC
This is not a bug; it's a deliberate upstream change.

If you have a JDBC driver that is using SET AUTOCOMMIT, you need to
update to a 7.4-compatible driver.  If you have an application that is
using SET AUTOCOMMIT, it's broken in itself, because only the driver
should be messing with that.


Note You need to log in before you can comment on or make changes to this bug.