Bug 1336368 - [virtio-win][viostor][virtio1.0]Cannot enlarge/shrink disk with virtio1.0 device
Summary: [virtio-win][viostor][virtio1.0]Cannot enlarge/shrink disk with virtio1.0 device
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Ladi Prosek
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-16 09:40 UTC by Yu Wang
Modified: 2016-11-04 08:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:54:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Yu Wang 2016-05-16 09:40:02 UTC
Description of problem:
Cannot enlarge/shrink disk with virtio1.0 device 
Guest OS: win2012R2/win10-64/win8-32, other guest should be the same problem.

Version-Release number of selected component (if applicable):
kernel-3.10.0-401.el7.x86_64
qemu-kvm-rhev-2.6.0-1.el7.x86_64
seabios-1.9.1-4.el7.x86_64
virtio-win10-prewhql-1-13

How reproducible:
100%

Steps to Reproduce:
1. boot with command line
  /usr/libexec/qemu-kvm -M pc -name win2012R2 -enable-kvm -m 3G -smp 4 -uuid f7356609-beb8-4ece-a330-82c12342ac05 -nodefconfig -nodefaults -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=win2012R2.raw,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:2 -vga cirrus -qmp tcp:0:4449,server,nowait -monitor stdio -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:3b:35:66:04 -device virtio-scsi-pci,id=scsi0,num_queues=4,disable-legacy=on,disable-modern=off -drive file=blk-disk.raw,if=none,id=drive-scsi-disk0,format=raw,serial=mike_cao,cache=none -device scsi-hd,bus=scsi0.0,drive=drive-scsi-disk0,id=scsi-disk0 -object iothread,id=thread0 -drive file=scsi-disk.raw,if=none,id=drive-virtio-disk0,format=raw,serial=mike_cao,cache=none -device virtio-blk-pci,scsi=off,drive=drive-virtio-disk0,iothread=thread0,id=virtio-disk0,disable-legacy=on,disable-modern=off -cdrom /home/106-netkvm-win2012R2-function/en_windows_server_2012_r2_x64_dvd_2707946.iso
2. enlarge the data disk of block device
{"execute":"block_resize","arguments":{"device":"drive-virtio-disk0","size":21474836480 }}
3. re-scan the disk on guest disk manager

Actual results:
The disk size did not change.

Expected results:
disk size should changed to 20G

Additional info:

1 boot guest w/o virtio1.0 device, cannot enlarge the disk too. (virtio-win10-prewhql-1-13)

2 after disable/enable the device, the disk size can change on disk manager.

Comment 3 Vadim Rozenfeld 2016-05-17 07:53:54 UTC
should be fixed in build 15 available for download from http://download.eng.bos.redhat.com/brewroot/work/tasks/8617/11038617/virtio-win10-prewhql-1.zip

Comment 5 Yu Wang 2016-05-17 10:21:07 UTC
verify this bug on build 15,

steps as comment#0
Actual results: can resize the disk successfully.

Above all, this bug has been fixed on virtio-win10-prewhql-1-15.

Thanks
wyu

Comment 6 Yu Wang 2016-05-17 10:30:26 UTC
change status to VERIFIED according to comment#5

Thanks
wyu

Comment 9 errata-xmlrpc 2016-11-04 08:54:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.