Bug 1336385 - Unclear warning when define deprecated --force-pull in s2i rebuild command
Summary: Unclear warning when define deprecated --force-pull in s2i rebuild command
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: source-to-image
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.3
Assignee: Tomas Hrcka
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-16 10:32 UTC by Wenjing Zheng
Modified: 2018-12-13 22:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-13 22:15:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wenjing Zheng 2016-05-16 10:32:45 UTC
Description of problem:
Unclear warning when define deprecated --force-pull in s2i rebuild command
[root@openshift-122 ~]# s2i rebuild haowang/rack-test-app haowang/rack-test-app:v1 --force-pull=false
E0516 06:13:15.087895 16994 main.go:352] An error occurred: the policy for pull image must be set

According to the help page of s2i rebuild, it says "--force-pull[=false]: DEPRECATED: Always pull the builder image even if it is present locally", there should be a friendly warning like s2i build: W0516 06:02:37.651281 15558 main.go:80] DEPRECATED: The '--force-pull' option is deprecated. Use '--pull-policy' instead

Version-Release number of selected component (if applicable):
https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=494336

How reproducible:
always

Steps to Reproduce:
1. build the image from source
   $ s2i build https://github.com/openshift/sti-php.git --context-dir=5.5/test/test-app registry.access.redhat.com/openshift3/php-55-rhel7 haowang/rack-test-app --incremental=true --loglevel=5
2. rebuild the images
  $ s2i rebuild haowang/rack-test-app:latest haowang/rack-test-app:v1 --force-pull=false 

Actual results:
[root@openshift-122 ~]# s2i rebuild haowang/rack-test-app haowang/rack-test-app:v1 --force-pull=false
E0516 06:13:15.087895 16994 main.go:352] An error occurred: the policy for pull image must be set

Expected results:
There should be a friendly warning about --force-pull is deprecated like s2i build: W0516 06:02:37.651281 15558 main.go:80] DEPRECATED: The '--force-pull' option is deprecated. Use '--pull-policy' instead warning 

Additional info:

Comment 2 Honza Horak 2018-12-13 22:15:23 UTC
Version 1.1.13, that we rebase to due to bz#1654243, returns this error: "unknown flag: --force-pull". Thus, I think we can close this an WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.