Bug 13364 - Rage XL graphical install problem
Rage XL graphical install problem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brock Organ
John Cagle
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-03 15:08 EDT by harry.heinisch
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-27 19:12:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description harry.heinisch 2000-07-03 15:08:29 EDT
While trying to install Beta-2 on a new server, it won't even get started 
with the installation.  After hitting "Return" at the initial boot prompt 
screen, here are the error messages I get:

==========================================================
Probing for mouse type...
Unknown card, falling back to VGA16
Traceback (innermost last):
  File "/usr/bin/anaconda", line 256, in ?
    result = xserver.startX ()
  File "/usr/bin/anaconda/xserver.py", line 84, in startX
    if not os.access (serverPath, os.X_OK):
TypeError: argument 1: expected string, None found
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime
        /mnt/source umount failed (16)
        /dev/pts
        /proc
you may safely reboot your system
==========================================================

If I use RedHat 6.2 on the same hardware, the server installs fine and 
works perfectly.  It has a Rage XL video controller.  Please email 
john.cagle@compaq.com for more information.
Comment 1 harry.heinisch 2000-07-06 11:50:52 EDT
Moved to beta3, since it's still a problem with beta3, and generates *exactly* 
the same error message during install.

I'm also moving this to Anaconda, since that may be more appropriate.  Please 
let me know if this is the best Component to post the bug to.

Thanks, John.Cagle@Compaq.Com.
Comment 2 Michael Fulbright 2000-07-12 16:45:31 EDT
Please verify in test lab...
Comment 3 Glen Foster 2000-07-18 15:59:32 EDT
This defect is considered MUST-FIX for Winston Beta-5
Comment 4 John Cagle 2000-07-20 23:42:36 EDT
STILL BROKEN in beta 4.  The error has changed slightly:

Probing for mouse type...
Found a Generic - 3 Button Mouse (USB)
Unknown card, falling back to VGA16
Traceback (innermost last):
  File "/usr/bin/anaconda", line 256, in ?
    result = xserver.startX ()
  File "/usr/lib/anaconda/xserver.py", line 99, in startX
    server = x.test ([':1', 'vt7', '-s', '1440', '-terminate'], spawn=1)
  File "/usr/lib/anaconda/xf86config.py", line 897, in test
    f.write (config (1))
  File "/usr/lib/anaconda/xf86config.py", line 1000, in Version3Config
    info = { "acceleratedDevices" : devices,
NameError: screens
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime
        /mnt/source umount failed (16)
        /dev/pts
        /proc
you may safely reboot your system
Comment 5 Glen Foster 2000-07-21 09:21:24 EDT
Compaq Computers considers this defect a must-fix defect for Winston release
(per Harry Heinisch on 21-Jul-2000).
Comment 6 Glen Foster 2000-07-21 14:41:45 EDT
Does this defect still exist with (on) Winston beta-4?
Comment 7 Michael Fulbright 2000-07-21 14:49:19 EDT
Could you please give us the PCI ids for this card, as well as its complete
model name?
Comment 8 John Cagle 2000-07-21 18:58:43 EDT
Yes, this still happens on beta 4.
The device (ATI Rage XL) is integrated on the motherboard.
Here's the device info from /proc/pci:

Bus  1, device   6, function  0:
  VGA compatible controller: ATI Unknown device (rev 39).
    Vendor id=1002. Device id=4752.
    Medium devsel.  Fast back-to-back capable.  IRQ 18.  Master Capable.  
Latency=66.  Min Gnt=8.
    Non-prefetchable 32 bit memory at 0xf6000000 [0xf6000000].
    I/O at 0x1800 [0x1801].
    Non-prefetchable 32 bit memory at 0xf5400000 [0xf5400000].
Comment 9 Matt Wilson 2000-07-27 19:12:25 EDT
Fixed in pinstripe(beta5)
Comment 10 Brock Organ 2000-08-30 10:21:59 EDT
verified fix ...

Note You need to log in before you can comment on or make changes to this bug.