Bug 1336459 - installing a package between Download and Install actions of graphical upgrade breaks graphical upgrade
Summary: installing a package between Download and Install actions of graphical upgrad...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: 1308538
TreeView+ depends on / blocked
 
Reported: 2016-05-16 14:24 UTC by Kamil Páral
Modified: 2016-07-20 23:50 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-07-20 23:50:07 UTC


Attachments (Terms of Use)
packagekitd verbose output during upgrade attempt (421.44 KB, text/plain)
2016-05-16 14:25 UTC, Kamil Páral
no flags Details
rpm-qa (46.54 KB, text/plain)
2016-05-16 14:25 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2016-05-16 14:24:34 UTC
Description of problem:
Following https://fedoraproject.org/wiki/QA:Testcase_Workstation_Graphical_Upgrade I did this:

1. Downloaded all packages for upgrade
2. switched to All tab in gnome software and installed a package (I installed gnome-sudoku)
3. after it was installed, switched back to Updates tab and clicked Install to perform the upgrade
4. nothing happened (no popup dialog asking to reboot, nothing). Clicked it again, and again, and again, nothing happened.

I had to reboot the machine to make gnome-software work again. After next boot, the Install button changed to Download, and when I clicked it, it downloaded the missing packages (gnome-sudoku.fc24) and Install then worked.

Version-Release number of selected component (if applicable):
gnome-software-3.20.3-0.191.20160425git.fc23.x86_64
libhif-0.2.3-0.145.20160427git.fc23.x86_64
PackageKit-1.1.1-1.fc23.x86_64

How reproducible:
2 out of 2 attempts

Actual results:
Install button breaks

Expected results:
if any package is installed before Install is pressed, it should change back to Download (or better Verify Download) to make sure all needed packages are downloaded and download the ones that are missing

Additional info:
In 1 of the 2 attempts, the whole upgrade banner in Updates tab disappeared, and I found out that 'fedora.json' file was reset from "Active" to "Under Development" in F24 section. I have no idea how that happened, it did not the second time.

Comment 1 Kamil Páral 2016-05-16 14:25:24 UTC
Created attachment 1157951 [details]
packagekitd verbose output during upgrade attempt

Comment 2 Kamil Páral 2016-05-16 14:25:29 UTC
Created attachment 1157952 [details]
rpm-qa

Comment 3 Kamil Páral 2016-05-16 14:43:49 UTC
The same thing happens when you use DNF to install a package between the Download and Install actions in gnome-software.

Comment 4 Richard Hughes 2016-05-25 10:27:41 UTC
I think this is fixed by:

commit 5a4b61bef7ec3b181221f8b583282850e2b58988
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed May 25 11:17:29 2016 +0100

    Invalidate the upgrade if the update list is changed
    
    Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=1336459

Comment 5 Richard Hughes 2016-05-26 14:59:26 UTC
I're re-fixed this and built a package in https://copr.fedorainfracloud.org/coprs/rhughes/f23-gnome320/build/317336/ -- testing very welcome -- thanks!

Comment 6 Fedora Update System 2016-05-28 18:37:54 UTC
gnome-software-3.20.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2be09c9861

Comment 7 Fedora Update System 2016-05-29 23:26:14 UTC
gnome-software-3.20.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2be09c9861

Comment 8 Fedora Update System 2016-05-30 21:18:38 UTC
gnome-software-3.20.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Kamil Páral 2016-05-31 11:17:21 UTC
I tested this with the following builds:
http://koji.fedoraproject.org/koji/buildinfo?buildID=768991
http://koji.fedoraproject.org/koji/buildinfo?buildID=762450
http://koji.fedoraproject.org/koji/buildinfo?buildID=768995
http://koji.fedoraproject.org/koji/buildinfo?buildID=769263
http://koji.fedoraproject.org/koji/buildinfo?buildID=762454
http://koji.fedoraproject.org/koji/buildinfo?buildID=762449

This is not fixed in my testing. When I download updates and then install some new package, the Install action does not change back to Download and therefore the issue is exactly as described in comment 0.

Comment 10 Kamil Páral 2016-06-06 15:56:23 UTC
Tested with https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf , still broken even in F23.

Comment 12 Fedora Update System 2016-07-12 19:14:22 UTC
PackageKit-1.1.2-1.fc23 appstream-data-23-11.fc23 fwupd-0.7.2-1.fc23 gnome-shell-3.18.5-2.fc23 gnome-software-3.20.4-1.fc23 json-glib-1.2.0-1.fc23 libappstream-glib-0.5.16-2.fc23 libgusb-0.2.9-1.fc23 libhif-0.2.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 13 Fedora Update System 2016-07-12 19:14:40 UTC
PackageKit-1.1.2-1.fc23 appstream-data-23-11.fc23 fwupd-0.7.2-1.fc23 gnome-shell-3.18.5-2.fc23 gnome-software-3.20.4-1.fc23 json-glib-1.2.0-1.fc23 libappstream-glib-0.5.16-2.fc23 libgusb-0.2.9-1.fc23 libhif-0.2.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 14 Kamil Páral 2016-07-13 14:18:00 UTC
This now seems fixed with the updates from comment 13. Tried installing a new package after download finished, or even during downloading.

Comment 15 Fedora Update System 2016-07-14 01:25:05 UTC
PackageKit-1.1.2-1.fc23, appstream-data-23-11.fc23, fwupd-0.7.2-1.fc23, gnome-shell-3.18.5-2.fc23, gnome-software-3.20.4-1.fc23, json-glib-1.2.0-1.fc23, libappstream-glib-0.5.16-2.fc23, libgusb-0.2.9-1.fc23, libhif-0.2.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 16 Fedora Update System 2016-07-14 13:27:56 UTC
PackageKit-1.1.3-1.fc23 appstream-data-23-11.fc23 fwupd-0.7.2-2.fc23 gnome-shell-3.18.5-2.fc23 gnome-software-3.20.4-1.fc23 json-glib-1.2.0-1.fc23 libappstream-glib-0.5.16-2.fc23 libgusb-0.2.9-1.fc23 libhif-0.2.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 17 Fedora Update System 2016-07-15 17:52:35 UTC
PackageKit-1.1.3-1.fc23, appstream-data-23-11.fc23, fwupd-0.7.2-2.fc23, gnome-shell-3.18.5-2.fc23, gnome-software-3.20.4-1.fc23, json-glib-1.2.0-1.fc23, libappstream-glib-0.5.16-2.fc23, libgusb-0.2.9-1.fc23, libhif-0.2.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 18 Fedora Update System 2016-07-20 23:49:35 UTC
PackageKit-1.1.3-1.fc23, appstream-data-23-11.fc23, fwupd-0.7.2-2.fc23, gnome-shell-3.18.5-2.fc23, gnome-software-3.20.4-1.fc23, json-glib-1.2.0-1.fc23, libappstream-glib-0.5.16-2.fc23, libgusb-0.2.9-1.fc23, libhif-0.2.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.