Bug 133646 - wget reports the length(file size) inaccurately
wget reports the length(file size) inaccurately
Status: CLOSED DUPLICATE of bug 123524
Product: Fedora
Classification: Fedora
Component: wget (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-25 12:33 EDT by Nathan G. Grennan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2004-09-25 12:33:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040916 Galeon/1.3.17.99

Description of problem:
wget reports the length(file size) of downloaded files inaccurately.
It seems to use different but roughly the same length each time.
Almost like it is actual size + really big number.

wget
http://unc.dl.sourceforge.net/sourceforge/vacation/vacation-1.2.6.1.tar.gz
--08:33:04-- 
http://unc.dl.sourceforge.net/sourceforge/vacation/vacation-1.2.6.1.tar.gz
           => `vacation-1.2.6.1.tar.gz'
Resolving unc.dl.sourceforge.net... 152.2.210.121
Connecting to unc.dl.sourceforge.net[152.2.210.121]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: B,446,744,069,414,632,154 [application/x-gzip]


Version-Release number of selected component (if applicable):
wget-1.9.1-16

How reproducible:
Always

Steps to Reproduce:
1. Install wget
2. wget url

    

Actual Results:  Inaccurate length

Expected Results:  Accruate length

Additional info:
Comment 1 Bernhard Erdmann 2004-09-26 11:40:27 EDT
I can confirm this bug of wget. It seems to be restricted to HTTP. FTP
does not show this bug (except when using an HTTP proxy, Squid
2.5STABLE6).

1st example (with bug):
wget-1.9.1 getting FTP URL via HTTP proxy (wget talks HTTP to proxy,
proxy talks FTP to server)
$ wget ftp://ftp.horde.org/pub/imp/imp-3.2.6.tar.gz
--17:35:57--  ftp://ftp.horde.org/pub/imp/imp-3.2.6.tar.gz
           => `imp-3.2.6.tar.gz'
Resolving www-cache... 192.168.1.6
Connecting to www-cache[192.168.1.6]:3128... connected.
Proxy request sent, awaiting response... 200 OK
Length: B,446,744,069,416,168,746 [application/x-tar]

    [                              <=>    ] 1,584,426    201.35K/s

17:36:05 (200.45 KB/s) - `imp-3.2.6.tar.gz' saved [1,584,426/1,584,426])

2nd example (without bug):
wget-1.9.1 getting FTP URL directly from server
$ wget -Y off ftp://ftp.horde.org/pub/imp/imp-3.2.6.tar.gz
--17:35:18--  ftp://ftp.horde.org/pub/imp/imp-3.2.6.tar.gz
           => `.listing'
Resolving ftp.horde.org... 199.175.137.145
Connecting to ftp.horde.org[199.175.137.145]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /pub/imp ... done.
==> PASV ... done.    ==> LIST ... done.

    [  <=>                                ] 5,124         24.18K/s

17:35:20 (24.15 KB/s) - `.listing' saved [5,124]

Unsupported listing type, trying Unix listing parser.
Removed `.listing'.
--17:35:20--  ftp://ftp.horde.org/pub/imp/imp-3.2.6.tar.gz
           => `imp-3.2.6.tar.gz'
==> CWD not required.
==> PASV ... done.    ==> RETR imp-3.2.6.tar.gz ... done.
Length: 1,584,426

100%[====================================>] 1,584,426    100.60K/s   
ETA 00:00

17:35:44 (64.45 KB/s) - `imp-3.2.6.tar.gz' saved [1,584,426]

3rd example (without bug):
wget-1.8.2, same setup with HTTP proxy as in 1st example
$ wget ftp://ftp.horde.org/pub/imp/imp-3.2.6.tar.gz
--17:36:33--  ftp://ftp.horde.org/pub/imp/imp-3.2.6.tar.gz
           => `imp-3.2.6.tar.gz'
Resolving www-cache... done.
Connecting to www-cache[192.168.1.6]:3128... connected.
Proxy request sent, awaiting response... 200 OK
Length: 1,584,426 [application/x-tar]

100%[====================================>] 1,584,426    200.43K/s   
ETA 00:00

17:36:41 (200.43 KB/s) - `imp-3.2.6.tar.gz' saved [1584426/1584426]
Comment 2 Michael Schwendt 2004-09-28 05:28:55 EDT
bug 123524 covers the LFS related problems
Comment 3 Karsten Hopp 2004-09-28 10:29:12 EDT

*** This bug has been marked as a duplicate of 123524 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:05:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.